[linux-dvb] Typhoon (KNC1 ?) COLD BOOT problem

Johannes Stezenbach js at linuxtv.org
Sun Dec 18 20:43:24 CET 2005


On Sat, Dec 10, 2005, Oliver Endriss wrote:
> Johannes Stezenbach wrote:
> > On Mon, Dec 05, 2005, Michael Rickmann wrote:
> > > The explanation for my problem seems relatively straightforward. After a cold 
> > > boot as defined above the stv0299 does not respond at the 
> > > SAA7146_I2C_BUS_BIT_RATE_120 used by the current driver.
> > > When I use SAA7146_I2C_BUS_BIT_RATE_3200 as the Metzler driver does the 
> > > frontend loads correctly but szap does not get a lock. I have also tried 
> > > SAA7146_I2C_BUS_BIT_RATE_240 and SAA7146_I2C_BUS_BIT_RATE_480.
> > > With these the Typhoon cold boots correctly and works properly.
...
> Either add a new field i2c_speed to struct budget,
> or use this simple patch:
> 
> --- budget-core.c.old	Sat Dec 10 21:48:13 2005
> +++ budget-core.c	Sat Dec 10 22:02:23 2005
> @@ -381,7 +381,11 @@ int ttpci_budget_init(struct budget *bud
>  
>  	strlcpy(budget->i2c_adap.name, budget->card->name, sizeof(budget->i2c_adap.name));
>  
> -	saa7146_i2c_adapter_prepare(dev, &budget->i2c_adap, SAA7146_I2C_BUS_BIT_RATE_120);
> +	if (bi->type == BUDGET_KNC1S)
> +		saa7146_i2c_adapter_prepare(dev, &budget->i2c_adap, SAA7146_I2C_BUS_BIT_RATE_480);
> +	else
> +		saa7146_i2c_adapter_prepare(dev, &budget->i2c_adap, SAA7146_I2C_BUS_BIT_RATE_120);
> +
>  	strcpy(budget->i2c_adap.name, budget->card->name);
>  
>  	if (i2c_add_adapter(&budget->i2c_adap) < 0) {
> 
> Anyway, this card seems to behave somewhat strange.
> Some people reported that enabling the master reset in saa7146-core.c
> fixed their problems...

It would be nice to get some feedback for this patch, but
maybe we should just commit it as it is obviously correct(tm).


Johannes



More information about the linux-dvb mailing list