[linux-dvb] Re: Lost lock problems over extended periods of time

Sebastian Frei Sebastian at schnapsleichen.de
Tue Jun 7 14:01:38 CEST 2005

Am Dienstag 07 Juni 2005 13:51 schrieb Andrew de Quincey:
> Hi, I've been having (another :) problem with the DVB drivers. Basically,
> at certain sites and with certain channels, cards seem to lose the lock
> after a while.... the average is about 10 hours, so I think its unlikely to
> be that multiswitch incompatability with certain TT DVB-S cards.
> This doesn't affect all sites or all channels or all cards - the same
> channels at another site can be rock solid with no issues for months.
> The driver is supposed to launch a zigzag scan if it loses lock. However
> this doesn't ever seem to regain the lock with this problem. Simply
> restarting our streaming software (without a reboot) however, _does_ regain
> the lock (only to lose it again after a while).
> Snooping with dvbsnoop shows that the signal has been lost, but it does
> appear to be zigzagging to try and require it, but failing (I see the lock
> status varying between SIGNAL and SIGNAL|CARRIER|VITERBI, but never above
> that).
> The difference between locking initially and losing a lock after a while
> seems to be the call to dvb_frontend_init(). I'm going to try adding a call
> to this in to the dvb_frontend_thread() loop if it loses the lock after a
> while.
> I'm wondering if anyone else sees this? It seems to plague us constantly.
> There does not appear to be any discernable pattern - we have a wide
> selection of TT DVB-S card vintages, and it can happen on any one of them,
> from cards that were bought 2 or 3 years ago to cards that were bought 2
> months ago. :(
> Does anyone have any ideas as to why it would be happening? The only thing
> I can come up with is that the frontends just lose the lock after a bit, so
> they need to be retuned to work around it.
> I suppose these cards are really meant as consumer grade ones for zapping
> channels, and not really designed for 24x7 reception on a single channel.
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb


I have very annoying problems with 2 Nova-S-CI (without CI pins, but need 
budget-ci drivers), maybe related to your problem.

After watching tv a while and zapping through different channels, I get an 
error in vdr:

Error: Can't get a lock on device 2

Femon tells the same. Restarting vdr without reloading the drivers cures the 

If you want me to try any patches, send them to me.


More information about the linux-dvb mailing list