[linux-dvb] Re: Firmware (dvb-ttusb-dec-3000s.fw) unavailable.

Markus Posch markus at posch.at
Wed Jun 8 08:45:40 CEST 2005


Markus Posch schrieb:
> nyk wrote:
> 
>>On Wed, Apr 13, 2005 at 09:34:27PM +0200, Markus Posch wrote:
>>
>>
>>>nyk schrieb:
>>>
>>>
>>>>On Wed, Apr 13, 2005 at 09:51:36AM +0200, Markus Posch wrote:
>>>>
>>>>
>>>>
>>>>>Hy @all.
>>>>>
>>>>>Now I had installet the release of kubuntu 5.04.
>>>>>
>>>>>but there is still this problem:
>>>>>
>>>>>when i connect the dec 3000 i got this in dmesg:
>>>>>
>>>>>Apr 13 09:15:46 localhost kernel: usb 3-1: new full speed USB device 
>>>>>using uhci_hcd and address 2
>>>>>Apr 13 09:15:57 localhost usb.agent[8890]:      ttusb_dec: loaded 
>>>>>successfully
>>>>>Apr 13 09:15:57 localhost kernel: ttusb_dec: Firmware 
>>>>>1.15<3>ttusb_dec_boot_dsp: Firmware (dvb-ttusb-dec-3000s.fw) unavailable.
>>>>>Apr 13 09:15:57 localhost kernel: usb_unlink_urb() is deprecated for 
>>>>>synchronous unlinks.  Use usb_kill_urb() instead.
>>>>>Apr 13 09:15:57 localhost last message repeated 3 times
>>>>>Apr 13 09:15:57 localhost kernel: usbcore: registered new driver ttusb-dec
>>>>>
>>>>>the firmware has the right name and is placd in /usr/lib/hotplug/firmware.
>>>>>
>>>>>the script dvb.sh and the rules are added.
>>>>>
>>>>>but there is still no adapter and no frontent in /dev.
>>>>
>>>>
>>>>Make sure udev is up to date.
>>>>
>>>>Make sure your kernel has CONFIG_FW_LOADER=m or CONFIG_FW_LOADER=y
>>>>
>>>>It might also help to modprobe the modules (modprobe ttusb_dec) before
>>>>plugging in the dec. Try unplugging and re-plugging in the dec.
>>>>
>>>>hth
>>>
>>>thanks,
>>>
>>>how can i see the my version of udev? (i think on the newest kubuntu is 
>>>should be the right one)
>>>
>>>today i saw the strangest thing.
>>>
>>>i called a friend who is working in the same firm. he said i should copy 
>>>the firmware to /lib/firmware.
>>>i made this, connected the dec => firmware loadet.
>>>
>>>ok. i go home from the firm, connected the dec => same error again??????
>>>
>>>i connected and disconnectet again and again, but the error is always 
>>>the same.
>>>
>>>now i am confused more then before.
>>>
>>
>>AIUI ubuntu has the same file layout as debian, so the firmware should
>>be in /usr/lib/hotplug/firmware. The only other thing I can think of is
>>that the permissions of the firmware file are wrong... is the file world
>>readable - that would make sure the hotplug process can read the file...
>>
>>nyk
> 
> hallo again,
> 
> now i installed the newest version of gentoo (only to try).
> 
> but no way to get the dec working.
> the dec is now build into the kernel and not a module.
> 
> but there was an interessting message in dmesg when i connect the dec.
> 
> Apr 26 07:28:37 localhost wait_for_sysfs[27603]: either wait_for_sysfs
> (udev 045) needs an update to handle the device
> '/devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0' properly (no bus
> device link) or the sysfs-support of your device's driver needs to be
> fixed, please report to <linux-hotplug-devel at lists.sourceforge.net>
> Apr 26 09:28:42 localhost ttusb_dec: Firmware 1.15<3>ttusb_dec_boot_dsp:
> Firmware (dvb-ttusb-dec-3000s.fw) unavailable.
> 
> I think there is a problem with my usb.
> 
> Anyone any idea?
> 
> 
> greets
> markus
> 
> 
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
> 

no i got an pcmcia2usb adapter because i thought that my usb controller 
was the problem.

but there is still the same problem. the only different is that the 
atapter use ohci and not uhci but the error is the same.

i have no idea anymore.

please help!!!!

greets
markus





More information about the linux-dvb mailing list