[linux-dvb] saa7134-dvb: tda1004x: pll set failed

Jan Tönjes jan.toenjes at web.de
Mon Aug 14 17:39:04 CEST 2006


Hi Hartmut!

Am Sonntag 13 August 2006 21:32 schrieb Hartmut Hackmann:
> HI. Jan
>
> Jan Tönjes wrote:
> > [...]
> >
> >>The point is this message:
> >>  Aug  8 11:53:18 alitoh tuner 0-004b: type set to tda8290+75a
> >>The driver expects another tuner. Looks like we have another case of
> >>hardware changes without changing the PCI ID.
> >>Please try forcing the card types 87 and 88 by giving the commands
> >>rmmod saa7134-dvb
> >>rmmod saa7134
> >>modprobe saa7134 card=87
> >>modprobe saa7134-dvb
> >>You need to do this *before* you do any action with the dvb device.
> >>other wise, you need to replug the card or power cycle the PC.
> >>
> >>Hartmut
> >
> > Hi!
> >
> > That was it! card=88 worked. Thanks a lot for your help!
> > If you need any more information for improoving the automatic detection
> > of the right card type, please contact me :-)
> >
> > Have a nice weekend...
>
> Did you test anlog TV and the baseband inputs too?

Watching analog TV, no problem. It autodetects card=60 and it is working very 
well. I am using kdetv. Only thing is, that I have to use sox to listen to 
the sound:

sox -c 2 -s -w -r 32000 -t ossdsp /dev/dsp1 -t ossdsp -w -r 32000 /dev/dsp

but thats stuff I can live with. I didn't test baseband inputs yet, but I can 
if you want. Anything I need to consider when trying?

> I would like to ask you to live with his for a while since i can't just add
> the PCI ID.

No problem ;-)


Greetings, 

Jan :-)



More information about the linux-dvb mailing list