[linux-dvb] Re: Pinnacle PCTV HD Pro Stick

Markus Rechberger mrechberger at gmail.com
Sun Dec 3 21:07:51 CET 2006


Hi,

On 12/3/06, Erik Meitner <erik at wanderings.us> wrote:
> Erik Meitner wrote:
> > Markus Rechberger wrote:
> >
> >> On 11/30/06, Erik Meitner <erik at wanderings.us> wrote:
> >>
> >>> Markus Rechberger wrote:
> >>>
> >>>> On 11/27/06, Chris Lawrence <lordsutch at gmail.com> wrote:
> >>>>
> >>>>> On 11/27/06, Markus Rechberger <mrechberger at gmail.com> wrote:
> >>>>>
> >>>>>> ok that's  just what I thought..
> >>>>>> can you retry with the repository on
> >>>>>> http://mcentral.de/hg/~mrec/v4l-dvb-kernel
> >>>>>>
> >>>>> That did it:
> >>>>>
> (snip)
> >>>>> Incidentally, I've had no luck with tvtime since using the v4
> >>>>> firmware... there are no obvious error messages in dmesg, but it
> >>>>> happens after loading the MN_NTSCPAL_A2 firmware:
> >>>>>
> >>>>> [ 2811.454000] xc3028_set_std, Loading specific configuration for
> >>>>> requested mode xc3028_MN_NTSCPAL_A2.i2c.fw
> >>>>>
> >>>>> It doesn't hang the system... it just stops and doesn't do anything.
> >>>>> The same problem occurs with kdetv.
> >>>>>
> >>>>> strace shows the freeze to be happening at
> >>>>>
> >>>>> ioctl(3, VIDIOC_DQBUF <unfinished ...>
> >>>>>
> >>>>> I can ^C out of it, at least.
> >>>>>
> >>>>>
> >>>> And this still works with the old firmware?
> >>>> (note do not load the dvb/atsc module, once you loaded it analogue TV
> >>>> will be switched off there's no switching back mechanism implemented
> >>>> for your device yet)
> >>>>
> >>>> Markus
> >>>>
> >>> Using the same code and doing "sudo modprobe em28xx i2c_scan=1" I get
> >>> the  exact same result as Chris using firmware V3 or V4.  tvtime  just
> >>> hangs and mplayer  reports "v4l2: select timeout".
> >>> Let me know if there is something you need done, tested, etc.
> >>>
> >>> Erik
> >>>
> >>>
> >>>
> >>>
> >> Can you send me the output after loading the em28xx with reg_debug=2?
> >>
> >> modprobe em28xx reg_debug=2
> >>
> >> (try to open a Tv application, close it and send me what it shows up
> >> in dmesg)
> >>
> >> thanks,
> >> Markus
> >>
> > I ran mplayer long enough to report four select timeouts.
> > Log  attached.
> >
> > Thanks,
> > Erik
> >
>
> Excellent. Using the latest
> http://linuxtv.org/hg/~mrechberger/v4l-dvb-kernel (e49a1bde8c5a) video
> and tuning work perfect.
> No audio initially. em28xx-audio is not automatically loaded. When
> loaded manually I had to run usbaudio_setup.sh after running tvtime.
>

we have a different firmware to get audio work, I'll put it online
during the next hours...
for good audio quality you will still have to wait until I'm back in
Austria for christmas where I have all my equipment for testing.
(unless someone else gets around to fix the quality earlier)

Markus



More information about the linux-dvb mailing list