[linux-dvb] SAA7146 / TDA10046H problem

Hartmut Hackmann hartmut.hackmann at t-online.de
Mon Dec 18 22:40:37 CET 2006


Hi, Nick

Nick Fearnley (Digital Media Projects Ltd.) wrote:
> Hi,
> 
> I have been having problems getting a TT-1500T to work as discussed 
> previously.  I get exactly the same on a KNC1 DVB-T card.  Essentially 
> it's the same architecture - although on the TT the TDA is external to 
> the tuner (a TD1316A) and the KNC uses the TU1216L.  Incidenttally I 
> needed to add the budget-av driver to the kernel to get the KNC even 
> recognised, the TT not requiring this.
> 
> Through dvbtune I get the following:
> 
> ./dvbtune -c 1 -f 626000000
> tda1004x: setting up plls for 53MHz sampling clock
> tda1004x: found firmware revision 29 -- ok
> Using DVB card "Philips TDA10046H DVB-T"
> tuning DVB-T (in United Kingdom) to 626000000 Hz
> polling....
> Getting frontend event
> FE_STATUS:
> polling....
> polling....
> 
> I have a completely different card in also (Nova-T - Conexant) which 
> tunes no problem so I know the feed is fine.
> 
> I must have something configured wrong here for both cards not to work 
> in the same way.  Maybe a kernel driver?  I do not enable module support 
> - all built into the kernel.  I have stripped everything I think I don't 
> require from the kernel.  Also all the DVB-S (SAA7146 and Conexant) that 
> I use work fine, so I'm assuming it MUST be TDA or tuner related here.  
> My timer is 1000Hz - but I'm not thinking this is an issue?
> 
> Thanks in advance for any pointers.
> 
> Nick
> 
The card has a TD1316 tuner? Can you find a chip named TDA9889 on the
card? If yes, the channel decoder needs to be programmed differently.

Hartmut



More information about the linux-dvb mailing list