[linux-dvb] SAA7146 / TDA10046H problem

Nick Fearnley (Digital Media Projects Ltd.) Nick at dmpip.tv
Tue Dec 19 14:14:06 CET 2006


I can't see that IC, could it be integrated into the can?  The tuner is a TD1316A/SIHP.

But the issue remains for the KNC variant of the budget DVB, the TU1216L tuner has the demod built in.  It exhibits exactly the same sypmtoms, recognised and firmware for the TDA10046HT loads fine but does not appear to get a lock on the frequency.  Most strange, I have noticed others have the same issue, certainly with the TT1500.

Surely other have had the budget DVB variants of DVB-T working OK?  As I have said, I don't have a problem with the DVB-S budget cards so it must be tuner/demod related.  Is there any debugging I could do to provide additional info?


-----Original Message-----
From: Hartmut Hackmann [mailto:hartmut.hackmann at t-online.de]
Sent: Mon 12/18/2006 9:40 PM
To: Nick Fearnley (Digital Media Projects Ltd.)
Cc: linux-dvb at linuxtv.org
Subject: Re: [linux-dvb] SAA7146 / TDA10046H problem
 
Hi, Nick

Nick Fearnley (Digital Media Projects Ltd.) wrote:
> Hi,
> 
> I have been having problems getting a TT-1500T to work as discussed 
> previously.  I get exactly the same on a KNC1 DVB-T card.  Essentially 
> it's the same architecture - although on the TT the TDA is external to 
> the tuner (a TD1316A) and the KNC uses the TU1216L.  Incidenttally I 
> needed to add the budget-av driver to the kernel to get the KNC even 
> recognised, the TT not requiring this.
> 
> Through dvbtune I get the following:
> 
> ./dvbtune -c 1 -f 626000000
> tda1004x: setting up plls for 53MHz sampling clock
> tda1004x: found firmware revision 29 -- ok
> Using DVB card "Philips TDA10046H DVB-T"
> tuning DVB-T (in United Kingdom) to 626000000 Hz
> polling....
> Getting frontend event
> FE_STATUS:
> polling....
> polling....
> 
> I have a completely different card in also (Nova-T - Conexant) which 
> tunes no problem so I know the feed is fine.
> 
> I must have something configured wrong here for both cards not to work 
> in the same way.  Maybe a kernel driver?  I do not enable module support 
> - all built into the kernel.  I have stripped everything I think I don't 
> require from the kernel.  Also all the DVB-S (SAA7146 and Conexant) that 
> I use work fine, so I'm assuming it MUST be TDA or tuner related here.  
> My timer is 1000Hz - but I'm not thinking this is an issue?
> 
> Thanks in advance for any pointers.
> 
> Nick
> 
The card has a TD1316 tuner? Can you find a chip named TDA9889 on the
card? If yes, the channel decoder needs to be programmed differently.

Hartmut

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20061219/f3088b4a/attachment.htm


More information about the linux-dvb mailing list