[linux-dvb] problem with tuner module

Jonathan Isom jeisom at gmail.com
Wed Dec 20 02:19:26 CET 2006


Hello
   I have a msi tv at nywhere plus  and a STB TV PCI FM, Gateway P/N
6000704.  When the msi  is detected first everything is detected
properly. when the stb is detected first the msi's tuner is not
detected .  The cards alternate when i reboot most times and I don't
know why.  PCI slot position doesn't appear to matter.


Thanks
    Jonathan

Here is dmesg from when it works



saa7133[0]: found at 0000:00:0b.0, rev: 209, irq: 18, latency: 30,
mmio: 0xdb800000
saa7133[0]: subsystem: 1462:6231, board: MSI TV at Anywhere plus
[card=82,autodetected]
saa7133[0]: board init: gpio is 40
input: MSI TV at nywhere Plus as /class/input/input3
ir-kbd-i2c: MSI TV at nywhere Plus detected at i2c-0/0-0030/ir0 [saa7133[0]]
bttv: driver version 0.9.16 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
saa7133[0]: i2c eeprom 00: 62 14 31 62 10 28 ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 10: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 20: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 40: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
tuner 0-004b: chip found @ 0x96 (saa7133[0])
tuner 0-004b: setting tuner address to 61
tuner 0-004b: type set to tda8290+75a
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0
saa7133[0]: registered device radio0
bttv: Bt8xx card found (0).
PCI: Enabling device 0000:00:13.0 (0004 -> 0006)
ACPI: PCI Interrupt 0000:00:13.0[A] -> GSI 18 (level, low) -> IRQ 19
bttv0: Bt878 (rev 2) at 0000:00:13.0, irq: 19, latency: 30, mmio: 0xdf000000
bttv0: detected: STB TV PCI FM, Gateway P/N 6000704 [card=40], PCI
subsystem ID is 10b4:2636
bttv0: using: STB TV PCI FM, Gateway P/N 6000704 (bt878), 3Dfx
VoodooTV 100 [card=40,autodetected]
bttv0: gpio: en=00000000, out=00000000 in=00ffffff [init]
tuner 2-0063: chip found @ 0xc6 (bt878 #0 [sw])
bttv0: using tuner=2
tuner 2-0063: type set to 2 (Philips NTSC (FI1236,FM1236 and compatibles))
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... found
tda7432 2-0045: chip found @ 0x8a (bt878 #0 [sw])
tvaudio 2-004c: tea6420 found @ 0x98 (bt878 #0 [sw])
tvaudio 2-005b: tda9850 found @ 0xb6 (bt878 #0 [sw])
bttv0: i2c: checking for TDA9887 @ 0x86... not found
bttv0: registered device video1
bttv0: registered device vbi1
bttv0: registered device radio1
bttv0: PLL: 28636363 => 35468950 .. ok
bt878: AUDIO driver version 0.0.0 loaded



More information about the linux-dvb mailing list