[linux-dvb] flydvb-t 301 not scanning

broza . brozada at gmail.com
Wed Dec 27 21:43:29 CET 2006


Hi,

I own a flyDVB-T card (saa7134) that is detected by current the kernel (
2.6.18 debian unstable for K7),
but don't works when trying to scan for dvb channels.
Also, I've tried with linuxtv mercurial sources, compiling and installing it
without trouble, but again no luck with scanning.

I enclose here more data:
# lspci -vv
···
00:0d.0 Multimedia controller: Philips Semiconductors SAA7134/SAA7135HL
Video Broadcast Decoder (rev 01)
        Subsystem: Animation Technologies Inc. Unknown device 0301
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 32 (21000ns min, 8000ns max)
        Interrupt: pin A routed to IRQ 169
        Region 0: Memory at b4000000 (32-bit, non-prefetchable) [size=1K]
        Capabilities: [40] Power Management version 1
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=1 PME-
···

saa7134 part of dmesg:
saa7134[0]: found at 0000:00:0d.0, rev: 1, irq: 169, latency: 32, mmio:
0xb4000000
saa7134[0]: subsystem: 5168:0301, board: LifeView FlyDVB-T / Genius
VideoWonder DVB-T [card=86,autodetected]
saa7134[0]: board init: gpio is 10000
saa7134[0]/core: hwinit1
input: saa7134 IR (LifeView FlyDVB-T / as /class/input/input3
saa7134[0]: i2c eeprom 00: 68 51 01 03 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7134[0]: i2c eeprom 10: 00 ff 86 0f ff 20 ff ff ff ff ff ff ff ff ff ff
saa7134[0]: i2c eeprom 20: 01 40 01 02 03 ff 01 03 08 ff 01 08 ff ff ff ff
saa7134[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7134[0]: i2c eeprom 40: ff 1b 00 c0 ff 10 ff ff ff ff ff ff ff ff ff ff
saa7134[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7134[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7134[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7134[0]/core: hwinit2
saa7134[0]/video: set tv norm = PAL
saa7134[0]/video: video input = 0 [Composite1]
saa7134[0]/video: set tv norm = PAL
saa7134[0]: registered device video1 [v4l2]
saa7134[0]: registered device vbi1
saa7134[0]/video: DCSDT: pll: not locked, sync: no, norm: (no signal)
DVB: registering new adapter (saa7134[0]).
saa7134 ALSA driver for DMA sound loaded
saa7134[0]/alsa: saa7134[0] at 0xb4000000 irq 169 registered as card -1
saa7134[0]/video: open minor=1 radio=0 type=video-cap
saa7134[0]/video: video input = 0 [Composite1]
saa7134[0]/video: set tv norm = PAL
saa7134[0]/video: set_control name=Brightness val=128
saa7134[0]/video: set_control name=Hue val=0
saa7134[0]/video: set_control name=Contrast val=68
saa7134[0]/video: set_control name=Saturation val=64
saa7134[0]/video: set_control name=Brightness val=128
saa7134[0]/video: set_control name=Hue val=0
saa7134[0]/video: set_control name=Contrast val=68
saa7134[0]/video: set_control name=Saturation val=64

tda10046 part:
tda1004x: setting up plls for 48MHz sampling clock
tda1004x: found firmware revision 23 -- ok

And scan result:
scan -v /usr/share/doc/dvb-utils/examples/scan/dvb-t/es-Madrid
scanning /usr/share/doc/dvb-utils/examples/scan/dvb-t/es-Madrid
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
initial transponder 770000000 0 2 1 3 1 3 0
initial transponder 810000000 0 2 1 3 1 3 0
initial transponder 834000000 0 2 1 3 1 3 0
initial transponder 842000000 0 2 1 3 1 3 0
initial transponder 850000000 0 2 1 3 1 3 0
initial transponder 858000000 0 2 1 3 1 3 0
>>> tune to:
770000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_1_2:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_4:HIERARCHY_NONE
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
WARNING: >>> tuning failed!!!
>>> tune to:
770000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_1_2:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_4:HIERARCHY_NONE
(tuning failed)
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
WARNING: >>> tuning failed!!!
···


Could anybody give me and advice on what happens?

Thanks in advance

Meu
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20061227/fa4fff38/attachment.htm


More information about the linux-dvb mailing list