[linux-dvb] No frontend with skystar2/pci and dvb-t stick

Eric Dujardin eric.dujardin at laposte.net
Thu Dec 28 17:34:34 CET 2006


Hello all,

I am trying to get my dvb-t stick to work, but I'm having troubles with 
frontends.

First I also have a Skystar-2 PCI adapter which has been working well 
for some time, running
kernel 2.6.17 (gentoo).

The USB stick is an Atopia AT-TV-USB3. It seems to be very close to a 
Dibcom reference design.

I recently built a 2.6.19-r2 kernel for it, added my stick's vid/pid and 
managed to load the firmware,
but in the end I had no frontend:
Dec 27 23:33:44 bouleau dvb-usb: no frontend was attached by 'Atopia 
AT-TV-USB3'

At that point my SS-2 was still fine:
Dec 27 23:24:28 bouleau DVB: registering new adapter (FlexCop Digital TV 
device).
Dec 27 23:24:28 bouleau b2c2-flexcop: MAC address = 00:d0:d7:0d:f3:09
Dec 27 23:24:28 bouleau b2c2-flexcop: found the stv0299 at i2c address: 0x68
Dec 27 23:24:28 bouleau DVB: registering frontend 0 (ST STV0299 DVB-S)...
Dec 27 23:24:28 bouleau b2c2-flexcop: initialization of 'Sky2PC/SkyStar 
2 DVB-S' at the 'PCI' bus controlled by a 'FlexCopIIb' complete

So I tried this morning's mercury snapshot, which has an enhanced 
stk7700p_frontend_attach(),
did make and make install, but now I have no frontend at all. I even 
tried to explicitely load
the stv0299 module, with no success:

Dec 28 16:41:18 bouleau b2c2-flexcop: B2C2 FlexcopII/II(b)/III digital 
TV receiver chip loaded successfully
Dec 28 16:41:18 bouleau flexcop-pci: will use the HW PID filter.   
Dec 28 16:41:18 bouleau flexcop-pci: card revision 2
Dec 28 16:41:18 bouleau ACPI: PCI Interrupt 0000:00:09.0[A] -> GSI 17 
(level, low) -> IRQ 17
Dec 28 16:41:18 bouleau DVB: registering new adapter (FlexCop Digital TV 
device).
Dec 28 16:41:18 bouleau b2c2-flexcop: MAC address = 00:d0:d7:0d:f3:09
Dec 28 16:41:18 bouleau DVB: Unable to find symbol stv0299_attach()
Dec 28 16:41:18 bouleau DVB: Unable to find symbol mt352_attach()
Dec 28 16:41:18 bouleau DVB: Unable to find symbol nxt200x_attach()
Dec 28 16:41:18 bouleau DVB: Unable to find symbol lgdt330x_attach()
Dec 28 16:41:18 bouleau DVB: Unable to find symbol bcm3510_attach()
Dec 28 16:41:18 bouleau DVB: Unable to find symbol stv0297_attach()
Dec 28 16:41:18 bouleau DVB: Unable to find symbol vp310_mt312_attach()
Dec 28 16:41:18 bouleau b2c2-flexcop: no frontend driver found for this 
B2C2/FlexCop adapter
........
Dec 28 16:41:18 bouleau dvb_usb_dib0700 
1-6.1:1.0:usb_probe_interface                                                                  

Dec 28 16:41:18 bouleau dvb_usb_dib0700 1-6.1:1.0: usb_probe_interface - 
got id
Dec 28 16:41:18 bouleau dvb-usb: found a 'DiBcom STK7700P reference 
design' in warm state.
Dec 28 16:41:18 bouleau dvb-usb: will pass the complete MPEG2 transport 
stream to the software demuxer.
Dec 28 16:41:18 bouleau DVB: registering new adapter (DiBcom STK7700P 
reference design).
Dec 28 16:41:18 bouleau dvb-usb: no frontend was attached by 'DiBcom 
STK7700P reference design'
Dec 28 16:41:18 bouleau dvb-usb: DiBcom STK7700P reference design 
successfully initialized and connected. 

I also tried the 20061209 snapshot with the same results.

I'm not sure if there's a real problem here, of if it's just me not 
using the v4l package as it should.

Some context finally: arch is x86_64, with glibc 2.4-r3 and gcc -v says:
Thread model: posix
gcc version 3.4.6 (Gentoo 3.4.6-r1, ssp-3.4.5-1.0, pie-8.7.9)

Thanks for any idea,

Eric







More information about the linux-dvb mailing list