[linux-dvb] Mantis 1034 DVB-S Scanning Problem

Michel Verbraak michel at verbraak.org
Sat Dec 30 11:46:50 CET 2006


Michel Verbraak schreef:
> Manu Abraham schreef:
>> Michel Verbraak wrote:
>>   
>>>
>>
>> machine locked up on a szap ? can you provide the logs when you szap 'ed
>> to this missing channel ?
>> Does this channel exist ? but even if it doesn't exist, i don't see any
>> reason why it should lock up.
>>
>> Manu
>>   
> Manu,
>
> I resolved this problem by restarting the mantis and mb86a16 modules 
> with the option verbose set to 0 (zero).
> I wrote a small script which did the szap for each channel and it 
> produced so many syslog writes, when verbose was 1, that my disk was 
> very active. I think the lockup came because of this.
>
> Currently I'm running my szap script on the different satellite for 
> the missing channels. Will be finished in about one hour, put some 
> sleep moments in there to be safe. I will post the result to this list 
> when finished.
>
> Regards,
>
> Michel.
> ------------------------------------------------------------------------
>
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb

I spoke to soon. During the test run all was fine, just one satellite 
which locked up the machine yesterday. But running my full test it did 
lock the machine.
The following happens just before the lockup: My windows still can get 
focus and be moved around but keyboard input is not shown or visible 
after about 30 seconds the mouse cursor freezes and the machine is 
completely locked up. Only a hard reset or power down will help.

I have seen this before in the past few days during the testing of a 
program i'm writing and debugging which will control the dvb-s card. 
Sometimes after a lot of channel changing I got the same result: lock up 
of the machine. I first put the blame on my programming but with all 
this I think it is the driver.

What I think is happening is that there is some kind of memory leak in 
the driver. I'm not sure but will do some more testing.

I must say that I also have a PVR-350, PVR-150 and a Freecom DVB-T USB 
devices connected to the same machine. But those were not use during the 
tests from this morning.

Michel.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20061230/d3410f21/attachment.htm


More information about the linux-dvb mailing list