[linux-dvb] Pinnacle 310i, DVB-T

tim0m1a tim0m1a at gmx.de
Sun Feb 12 12:38:58 CET 2006


Hi,

you would have some trouble to get the pinnacle running under  
kernel-versions newer than 2.6.12 but as you use a 2.6.12-Kernel-Version  
you should try this v4l-snapshot:
http://www.linuxtv.org/downloads/video4linux/video4linux-20050627.tar.gz
This works fine for me, but it is the only snapshot working on my machine.

Just install the snapshot and load the card with modprobe "saa7134_dvb".
Do not load the card-driver before or give any parameters to the module.  
It should work without it.

Please keep in mind, that you must flash at least the 1.11-Firmware  
version onto your card via Windows, otherwise the card would not work.

Regards,
Tim

Am Sun, 12 Feb 2006 11:32:12 +0100 schrieb Pierluigi 'Lanugo' Rolando  
<lanugo at ica-net.it>:

>> If I understand it correctly, this means that the firmware is uploaded,
>> not everything goes well.
>
> I've just made another try. I booted Windows, recorded a show
> broadcasted in DVB-T, then rebooted linux.
> This is what I've got after unloading saa7134 card=77, loading saa7134
> card=81, modprobing saa7134-dvb and running the scan utility:
>
> dmesg output --
> [4294771.134000] ACPI: PCI Interrupt 0000:05:07.0[A] -> Link [APC2] ->
> GSI 17 (l evel, low) -> IRQ 17
> [4294771.134000] saa7133[0]: found at 0000:05:07.0, rev: 208, irq: 17,
> latency: 32, mmio: 0xd900a000
> [4294771.134000] saa7133[0]: subsystem: 11bd:002f, board: Philips Tiger
> referenc e design [card=81,insmod option]
> [4294771.134000] saa7133[0]: board init: gpio is 600e000
> [4294771.268000] tuner 0-004b: chip found @ 0x96 (saa7133[0])
> [4294771.300000] tuner 0-004b: setting tuner address to 61
> [4294771.325000] tuner 0-004b: tuner: type set to tda8290+75a
> [4294771.361000] saa7133[0]: i2c eeprom read error (err=-5)
> [4294773.288000] saa7133[0]: registered device video0 [v4l2]
> [4294773.289000] saa7133[0]: registered device vbi0
> [4294773.291000] saa7133[0]: registered device radio0
> [4294782.509000] DVB: registering new adapter (saa7133[0]).
> [4294782.509000] DVB: registering frontend 0 (Philips TDA10046H
> DVB-T)...
> [4294812.785000] tda1004x: setting up plls for 48MHz sampling clock
> [4294812.942000] tda1004x: found firmware revision 29 -- ok
> [4294812.948000] tda1004x: pll init failed
> [4294812.964000] tda1004x: pll set failed
> [4294813.165000] tda1004x: pll set failed
> [4294813.367000] tda1004x: pll set failed
> [4294813.569000] tda1004x: pll set failed
> [4294813.771000] tda1004x: pll set failed
> [4294813.973000] tda1004x: pll set failed
> [4294814.176000] tda1004x: pll set failed
> [4294814.377000] tda1004x: pll set failed
> [4294814.578000] tda1004x: pll set failed
> [4294814.780000] tda1004x: pll set failed
> [4294814.982000] tda1004x: pll set failed
> [4294815.184000] tda1004x: pll set failed
> --
>
> scan fails the usual way:
> --
> scanning it-Torino
> using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
> initial transponder 834000000 0 1 0 3 1 3 0
> initial transponder 514000000 0 1 0 3 1 3 0
> initial transponder 474000000 0 1 0 3 1 3 0
> initial transponder 850000000 0 1 0 3 1 3 0
> initial transponder 602000000 0 1 0 3 1 3 0
> initial transponder 650000000 0 1 0 3 1 3 0
>>>> tune to:
> 834000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_1_2:FEC_NONE:QAM_64:TR
> ANSMISSION_MODE_8K:GUARD_INTERVAL_1_4:HIERARCHY_NONE
> __tune_to_transponder:1290: ERROR: FE_READ_STATUS failed: 5 Input/output
> error
>>>> tune to:
> 834000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_1_2:FEC_NONE:QAM_64:TR
> ANSMISSION_MODE_8K:GUARD_INTERVAL_1_4:HIERARCHY_NONE
> __tune_to_transponder:1290: ERROR: FE_READ_STATUS failed: 5 Input/output
> error
>>>> tune to:
> 514000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_1_2:FEC_NONE:QAM_64:TR
> ANSMISSION_MODE_8K:GUARD_INTERVAL_1_4:HIERARCHY_NONE
> [and so on]
> --
>
> So I suppose that the with this card the firmware has to be loaded, and
> it is correctly loaded with Windows. Then it survives the reboot, but
> the PLL still isn't initialized and set correctly by the tda1004x
> module.
>
> Is there anybody more knowledgeable than me willing to help? What should
> I try now?
>
> Thank you,
> Pierluigi Rolando
>
>
>
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
>





More information about the linux-dvb mailing list