[linux-dvb] videodev.ko not installed when using v4l-dvb (HG) and conflicting symbols

Stone syphyr at gmail.com
Mon Feb 27 13:03:06 CET 2006


I just tried testing the new HG branch of v4l-dvb with linux kernl
2.6.16-rc5 and have come across a few minor issues.

1)  If I have any dvb modules built in the kernel before building v4l-dvb
outside the tree, the symbols seem to conflict when trying to load the HG
modules.  Fix: Disable all DVB modules in kernel before building dvb modules
outside the tree.

saa7146_vv: disagrees about version of symbol video_unregister_device
saa7146_vv: Unknown symbol video_unregister_device
saa7146_vv: disagrees about version of symbol video_device_alloc
saa7146_vv: Unknown symbol video_device_alloc
saa7146_vv: disagrees about version of symbol video_register_device
saa7146_vv: Unknown symbol video_register_device
saa7146_vv: disagrees about version of symbol video_device_release
saa7146_vv: Unknown symbol video_device_release
dvb_ttpci: Unknown symbol saa7146_vv_init
dvb_ttpci: Unknown symbol saa7146_vv_release
dvb_ttpci: Unknown symbol saa7146_start_preview
dvb_ttpci: Unknown symbol saa7146_unregister_device
dvb_ttpci: Unknown symbol saa7146_register_device
dvb_ttpci: Unknown symbol saa7146_set_hps_source_and_sync
dvb_ttpci: Unknown symbol saa7146_stop_preview


2) After doing "make install", there is no videodev.ko in
/lib/mod/{kernel}/kernel/drivers/media/video/videodev.ko.  Something is
wrong with the Makefile where it is not installing videodev.ko.  If
videodev.ko does not exist, I get the following error:

saa7146_vv: Unknown symbol video_unregister_device
saa7146_vv: Unknown symbol video_device_alloc
saa7146_vv: Unknown symbol video_register_device
saa7146_vv: Unknown symbol video_usercopy
saa7146_vv: Unknown symbol video_device_release


Thanks,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20060227/e767a4c5/attachment.htm


More information about the linux-dvb mailing list