[linux-dvb] Typhoon DVB-T Duo Digital/Analog Cardbus - tuning not possible

Hartmut Hackmann hartmut.hackmann at t-online.de
Mon Jan 2 22:01:08 CET 2006


Hi, Matthias

Matthias H. wrote:
> Hello,
> 
> i am trying to get the mentioned card to work on my notebook (pcmcia) 
> and i have trouble on tuning it with
> Kernel 2.6.14.4, Debian testing. - Nothing works, not analog tv, not 
> digital tv.
> So when i do a "scan" with my frequency table file (dvb-de-ruhrgebiet) i 
> get lots of tuning errors like:
> "WARNING: >>> tuning failed!!!" with "scan -vv" i additionally get: ">>> 
> tuning status == 0x00"
> Sometimes, but not evehury time i try to scan, i get:
> "__tune_to_transponder:1290: ERROR: FE_READ_STATUS failed: 5 
> Input/output error"
> 
> I think i am using the wrong tuner for the card. So i wrote a simple 
> test script for probing all tuners, but that did not help, perhaps i 
> have done something wrong...
> 
> dmesg:
> saa7133[0]: found at 0000:02:00.0, rev: 240, irq: 9, latency: 0, mmio: 
> 0x22000000
> saa7133[0]: subsystem: 4e42:0502, board: Typhoon DVB-T Duo 
> Digital/Analog Cardbus [card=60,insmod option]
> saa7133[0]: board init: gpio is e010000
> saa7133[0]: dsp access wait timeout [bit=WRR]
> saa7133[0]: dsp access wait timeout [bit=WRR]
> saa7133[0]: dsp access wait timeout [bit=WRR]
> saa7133[0]: i2c eeprom 00: 42 4e 02 05 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
> saa7133[0]: i2c eeprom 10: 00 ff 22 0f ff 20 ff ff ff ff ff ff ff ff ff ff
> saa7133[0]: i2c eeprom 20: 01 40 01 03 03 01 01 03 08 ff 01 81 ff ff ff ff
> saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
> saa7133[0]: i2c scan: found device @ 0x10  [???]
> saa7133[0]: i2c scan: found device @ 0x96  [???]
> saa7133[0]: i2c scan: found device @ 0xa0  [eeprom]
> tuner 0-004b: chip found @ 0x96 (saa7133[0])
> tuner 0-004b: tuner: type set to tda8290+75
> saa7133[0]: registered device video0 [v4l2]
> saa7133[0]: registered device vbi0
> saa7133[0]: registered device radio0
> DVB: registering new adapter (saa7133[0]).
> DVB: registering frontend 0 (Philips TDA10046H DVB-T)...
> 
> 

First of all, you shoould use the most recent drivers from the CVS.
There might be 2 versions of this card. One is almost identical to the
Lifeview Duo. This one should work but it doesn't perform well.
There is a new design with a new tuner. I am working on this one.
If you use the driver from CVS, it might tell you that the tuner
is tda8290+75a. In this case, it is the new design.

Best regards
    Hartmut



More information about the linux-dvb mailing list