[linux-dvb] Integrated saa7133 not working

damien damien.thebault at laposte.net
Fri May 26 13:25:50 CEST 2006


I just purchased a new laptop (acer 5652 WLMi) which comes with an
integrated analogic+numeric(DVB-T) TV card.

I'm currently running Ubuntu dapper, the saa7134 driver is loading
and /dev/video0 is created. However I only have one "channel" (under
tvtime video source is "default").
I don't have /dev/dvb/ too.

Here are the lspci and driver output :

 % lspci -vvv -s 06:02
0000:06:02.0 Multimedia controller: Philips Semiconductors SAA7133 Video
Broadcast Decoder (rev d1)
        Subsystem: Avermedia Technologies Inc: Unknown device a836
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 64
        Interrupt: pin A routed to IRQ 74
        Region 0: Memory at d2201800 (32-bit, non-prefetchable)
[size=2K]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-



[4294691.009000] saa7130/34: v4l2 driver version 0.2.14 loaded
[4294691.009000] PCI: Enabling device 0000:06:02.0 (0000 -> 0002)
[4294691.009000] ACPI: PCI Interrupt 0000:06:02.0[A] -> GSI 22 (level,
low) -> IRQ 74
[4294691.009000] saa7133[0]: found at 0000:06:02.0, rev: 209, irq: 74,
latency: 0, mmio: 0xd2201800
[4294691.009000] PCI: Setting latency timer of device 0000:06:02.0 to 64
[4294691.009000] saa7133[0]: subsystem: 1461:a836, board:
UNKNOWN/GENERIC [card=0,autodetected]
[4294691.009000] saa7133[0]: board init: gpio is a400000
[4294691.137000] saa7133[0]: i2c eeprom 00: 61 14 36 a8 00 00 00 00 00
00 00 00 00 00 00 00
[4294691.137000] saa7133[0]: i2c eeprom 10: ff ff ff ff ff 20 ff ff ff
ff ff ff ff ff ff ff
[4294691.137000] saa7133[0]: i2c eeprom 20: 01 40 01 02 02 01 01 03 08
ff 00 c0 ff ff ff ff
[4294691.137000] saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff
ff ff ff ff ff ff ff
[4294691.137000] saa7133[0]: i2c eeprom 40: ff 65 00 ff c2 1e ff ff ff
ff ff ff ff ff ff ff
[4294691.137000] saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff
ff ff ff ff ff ff ff
[4294691.137000] saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff
ff ff ff ff ff ff ff
[4294691.137000] saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff
ff ff ff ff ff ff ff
[4294691.137000] saa7133[0]: registered device video0 [v4l2]
[4294691.137000] saa7133[0]: registered device vbi0
[4294691.323000] saa7134 ALSA driver for DMA sound loaded
[4294691.323000] saa7133[0]/alsa: saa7133[0] at 0xd2201800 irq 74
registered as card -1

I don't know what to do to get this card working.

I own a bt848 TV card on my dektop computer, but it'd not a DVB card,
maybe the configuration/softwares are different since I don't know
really how DVB works under Linux.

I tried some cards of the saa7134 module with no good results.

-- 
Damien Thebault

Key C15AB8AF
Fingerprint 8FB9 8576 7033 4B45 3DF5  88E8 5471 1A44 C15A B8AF
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 191 bytes
Desc: Ceci est une partie de message
	=?ISO-8859-1?Q?num=E9riquement?= =?ISO-8859-1?Q?_sign=E9e?=
Url : http://www.linuxtv.org/pipermail/linux-dvb/attachments/20060526/c9e1237e/attachment.pgp


More information about the linux-dvb mailing list