[linux-dvb]AVerTV Hybrid+FM PCI

Unknown cameta at gmail.com
Fri Nov 10 21:23:05 CET 2006


Hello,
I have tried to install the AVerTV Hybrid+FM PCI.
Looking inside the card we can see that it has the next chips:

Philips SAA7135HL/203
Zarlink MT352 
XCEIVE XC3018 ACQ


hg clone http://linuxtv.org/hg/v4l-dvb
cd v4l-dvb
make
make install
In the cardlist.saa7134 I didn't found my card but I have tried this:

modprobe saa7134 card=99 
modprobe saa77134_dvb

with the next result:

saa7133[0]: found at 0000:02:07.0, rev: 209, irq: 22, latency: 32, mmio:
0xd3005000
saa7133[0]: subsystem: 1461:f936, board: AVerMedia TV Hybrid A16AR
[card=99,insmod option]
saa7133[0]: board init: gpio is 2fa00
saa7133[0]: i2c eeprom 00: 61 14 36 f9 00 00 00 00 00 00 00 00 00 00 00
00
saa7133[0]: i2c eeprom 10: ff ff ff ff ff 20 ff ff ff ff ff ff ff ff ff
ff
saa7133[0]: i2c eeprom 20: 01 40 01 02 02 01 01 00 08 ff 00 0e ff ff ff
ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
ff
saa7133[0]: i2c eeprom 40: ff 65 00 ff c2 1e ff ff ff ff ff ff ff ff ff
ff
saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
ff
saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
ff
saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
ff
tuner 3-0061: chip found @ 0xc2 (saa7133[0])
tuner 3-0061: type set to 62 (Philips TEA5767HN FM Radio)
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0
saa7133[0]: registered device radio0
saa7133[0]: avertv 777 dvb setup
mt352_read_register: readreg error (reg=127, ret==-5)
saa7133[0]: frontend initialization failed
This isn't working.

After this I have tried the next option:

modprobe saa7134 card=85 
modprobe saa77134_dvb

saa7133[0]: found at 0000:02:07.0, rev: 209, irq: 22, latency: 32, mmio:
0xd3005000
saa7133[0]: subsystem: 1461:f936, board: AverTV DVB-T 777
[card=85,insmod option]
saa7133[0]: board init: gpio is effffff
saa7133[0]: i2c eeprom 00: 61 14 36 f9 00 00 00 00 00 00 00 00 00 00 00
00
saa7133[0]: i2c eeprom 10: ff ff ff ff ff 20 ff ff ff ff ff ff ff ff ff
ff
saa7133[0]: i2c eeprom 20: 01 40 01 02 02 01 01 00 08 ff 00 0e ff ff ff
ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
ff
saa7133[0]: i2c eeprom 40: ff 65 00 ff c2 1e ff ff ff ff ff ff ff ff ff
ff
saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
ff
saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
ff
saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
ff
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0
saa7133[0]: avertv 777 dvb setup
DVB: registering new adapter (saa7133[0]).
DVB: registering frontend 0 (Zarlink MT352 DVB-T)...

With this option I can see the signal from a S-Video source but I can't
tuning to any channel:
  scan dvb-apps-92cd5208d2cf/util/scan/dvb-t/es-Mussara | tee
channels.conf
scanning dvb-apps-92cd5208d2cf/util/scan/dvb-t/es-Mussara
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
initial transponder 778000000 0 2 9 3 1 3 0
initial transponder 818000000 0 2 9 3 1 3 0
initial transponder 834000000 0 2 9 3 1 3 0
initial transponder 842000000 0 2 9 3 1 3 0
initial transponder 850000000 0 2 9 3 1 3 0
initial transponder 858000000 0 2 9 3 1 3 0
>>> tune to:
778000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_4:HIERARCHY_NONE
WARNING: >>> tuning failed!!!

Thanks in advance and sorry for my English.




More information about the linux-dvb mailing list