[linux-dvb] Pinnacle 400e USB DVB-S something to try

Andrew de Quincey adq_dvb at lidskialf.net
Fri Nov 17 02:56:00 CET 2006


On Wednesday 18 October 2006 08:43, Patrick Boettcher wrote:
> On Tue, 17 Oct 2006, Andrea Venturi wrote:
> > dvb-usb: Pinnacle 400e DVB-S USB2.0 successfully initialized and
> > connected. divide error: 0000 [#1]
> > PREEMPT
> > Modules linked in: lnbp21 tda826x tda10086 dvb_usb_ttusb2 dvb_usb
> > dvb_core dvb_pll vmnet vmmon rfco
> > mm l2cap bluetooth ipv6 autofs4 thermal fan button ac battery i2c_i801
> > speedstep_centrino freq_tabl
> > e processor nvidia i2c_core usbhid usb_storage 8250_pci snd_intel8x0m
> > snd_intel8x0 8250_pnp snd_ac9
> > 7_codec snd_ac97_bus pcmcia snd_pcm_oss snd_mixer_oss crc32 snd_pcm
> > snd_timer ipw2200 snd soundcore
> >  ieee80211 ieee80211_crypt irda ehci_hcd uhci_hcd psmouse intel_agp
> > agpgart snd_page_alloc yenta_so
> > cket rsrc_nonstatic pcspkr evdev firmware_class 8250 rtc parport_pc
> > parport crc_ccitt tg3 usbcore s                  erial_core
> > CPU:    0
> > EIP:    0060:[<f8bd79df>]    Tainted: P      VLI
> > EFLAGS: 00210246   (2.6.17 #1)
> > EIP is at tda10086_set_frontend+0x311/0x3f6 [tda10086]
> > eax: 002edfff   ebx: 00000000   ecx: 00000000   edx: 00000000
> > esi: 00000000   edi: 00000004   ebp: db13df6c   esp: db13df3c
> > ds: 007b   es: 007b   ss: 0068
> > Process kdvb-fe-0 (pid: 11106, threadinfo=db13c000 task=da7670f0)
> > Stack: 00000000 00000000 01000008 00000000 00000000 f3d57a00 000176ff
> > 04004343
> >        0010bd28 d9d82400 f3d57a08 00000000 db13df94 f8ccb631 f3d57a08
> > d9d82404
> >        00000000 00000002 0010bd28 d9d82400 f3d57a08 db13dfc4 db13dfa8
> > f8ccbdd2
> > Call Trace:
> >  <c0103d58> show_stack_log_lvl+0x85/0x8f  <c0103ee6>
> > show_registers+0x14f/0x1c3
> >  <c01040b7> die+0x15d/0x231  <c0104205> do_trap+0x7a/0x98
> >  <c01047be> do_divide_error+0x87/0x91  <c010381f> error_code+0x4f/0x54
> >  <f8ccb631> dvb_frontend_swzigzag_autotune+0x17d/0x1a8 [dvb_core]
> > <f8ccbdd2> dvb_frontend_swzigzag                  +0x1a5/0x206 [dvb_core]
> >  <f8cccb2f> dvb_frontend_thread+0x25c/0x2de [dvb_core]  <c0101005>
> > kernel_thread_helper+0x5/0xb
> > Code: ff ff 8b 45 e4 89 d9 ba 07 00 00 00 c1 eb 08 e8 04 fb ff ff 8b 45
> > e4 89 d9 ba 08 00 00 00 e8                   f5 fa ff ff 8d 86 ff df 2e
> > 00 31 d2 <f7> f6 ba 09 00 00 00 89 c1 8b 45 e4 e8 dc fa ff ff 0f b6 4d e
> >                  d
> > EIP: [<f8bd79df>] tda10086_set_frontend+0x311/0x3f6 [tda10086] SS:ESP
> > 0068:db13df3c
> > ============================
> >
> > that's all as a first report. let me know if you need more info.
>
> This is a problem in the tda10086-module - but I'm unable to see it.
> Andrew, can you take a look, please?

Hmm, there are several places - I'm assuming the stacktrace is knackered and 
is sticking at set_frontend.

Is this reproducable easily? If so, I can hack a debug patch together...



More information about the linux-dvb mailing list