[linux-dvb] Pre-packaged vdr 1.4.3 decrypting fails?

Klaus Schmidinger Klaus.Schmidinger at cadsoft.de
Tue Nov 21 08:24:52 CET 2006


Otto J. Makela wrote:
> Klaus Schmidinger wrote:
>> Otto J. Makela wrote:
>>> Klaus Schmidinger wrote:
>>> ...
>>> Nov 18 02:03:44 piglet vdr: [10643] switching to channel 44
>> Actually VDR should wait at this point until all CAMs are ready,...
>>
>>> ...
>>> Nov 18 02:03:44 piglet vdr: [10643] timer 3 (44 0050-0210 'Is It Real?:
> ...
>>> Nov 18 02:03:59 piglet vdr: [10647] CAM: Conax 4.00e, 01, 0B00, 04B1
>> ...but the CAM only gets ready here, when the timer has already
>> started recording.
>>
>> Are there any patches involved that might disturb this?
> 
> It seems this ready-made vdr-1.4.3-3.fc5 has quite many patches included:
> 
> Patch0: %{name}-channel+epg.patch
> Patch1:
> http://zap.tartarus.org/~ds/debian/dists/unstable/main/source/vdr_1.4.3-1.ds.diff.gz
> Patch2:
> http://www.saunalahti.fi/~rahrenbe/vdr/patches/vdr-1.4.3-liemikuutio-1.13.diff.gz
> Patch3: %{name}-1.4.1-paths.patch
> Patch4: %{name}-1.4.1-dumpable.patch
> Patch10: ftp://ftp.cadsoft.de/vdr/Developer/vdr-1.4.3-1.diff
> 
> Isn't the subtitle patch to vdr needed to be able to do dvb/teletext subtitle
> capture, and not including it here would make the separate vdr-subtitle rpm
> package quite useless?

Well, I guess you should first try to get decryption working at all.
Then you can go on with patches etc.

>> Have you tried "plain vanilla" VDR, yet?
> 
> I was thinking of doing it next, do you think I should go for 1.4.3 or 1.4.4?
> Are there any "must have" patches to get either working at a basic level?

I'm running VDR completely unpatched here, and it works just fine
with my CAMs.

Klaus



More information about the linux-dvb mailing list