[linux-dvb] Switching tuner to analogue mode on Compro VideoMate DVB-T300

Hartmut Hackmann hartmut.hackmann at t-online.de
Mon Oct 2 01:08:25 CEST 2006


Hi,

Tomislav Bodor wrote:
> Hi,
> 
> I am having problems getting the DVB-T300 to switch to analogue mode
> once the digital part of the tuner has been accessed. The only way I
> found seems to be to unload the saa7134-dvb module and reload saa7134.
> I'm using the drivers from vanilla 2.6.18 kernel, but I checked the
> relevant sections (see below) against mercurial and they seem to be the
> same.
> 
> Now, I have had a look at how this is supposed to be switched back to
> analogue and have found the sleep function (the one used for DVB-T300 is
> philips_europa_tuner_sleep) and the way it's called from dvb_frontent.c
> after dvb_shutdown_timeout expires. This all seems to work (and the
> sleep function is called correctly), but the tuner stays in digital mode.
> 
> Does anyone have an idea why this might not work? Maybe the i2c messages
> are wrong for this card? Unfortunately this is all completely new to me,
> but I'm happy to test any patches :)
> 
> 
There have been 2 big changes since i added support for this card.
I worried about the tda9887 merge in the tuner module, but the
effect i worried about is a bit different from what you describe.
- are there any error messages in the kernel log?
- does analog tv work immedeately after module load?
Any additional information will help.

Best regards
    Hartmut



More information about the linux-dvb mailing list