[linux-dvb] Pinnacle 310i DVB-T, please try this patch

Emilio Castellano ecastellano at microgenesis.es
Thu Oct 5 11:09:08 CEST 2006


KevinLuX wrote:
> Hartmut Hackmann ha scritto:
>> Hi, Folks
>>
>> This patch should make make the Pinnacle 310i DVB-T working.
>> It is based on the patch by Pierluigi_Rolando and should apply
>> to the v4l-dvb repository at http://www.linuxtv.org of today.
>> I don't have this card, so i need you to test it.
>> The card should be fully working except remote control
>> if there is one.
>> I assume the radio is based on the tda8290, TDA8275a, hope
>> this is right. You still need to tune manually.
>>
>> Please test whatever you can and report.
> It works !!
> Here my configuration :
> Ubuntu 6.06 - Kernel Vanilla 2.6.18 - v4l-dvb from today 05 October 2006.
> 
> Here my step.
> 
> 1- cd v4l dir
> 2- patch -p1 < pinnacle........patch
> 3- make all & make install
> 4- perl *path_to_v4l_dir*/linux/Documentation/dvb/get_dvb_firmware tda10046
> 5- cp 
> *path_to_v4l_dir*/linux/Documentation/dvb/get_dvb_firmware/dvb-fe-tda10046.fw  
> /lib/firmware
> 6- only for my personal reason i prefer to load manually the module so i 
> put in /etc/modprobe.d/blacklist the line: blacklist saa7134
> 7- reboot
> 
> On new session :
> 
> 8- modprobe saa7134
> 
> ------------ KERNEL MESSAGES -------------
> 
> Linux video capture interface: v2.00
> saa7130/34: v4l2 driver version 0.2.14 loaded
> OcACPI: PCI Interrupt Link [APC2] enabled at IRQ 17
> OACPI: PCI Interrupt 0000:01:09.0[A] -> Link [APC2] -> GSI 17 (level, 
> high) -> IRQ 21
> saa7133[0]: found at 0000:01:09.0, rev: 208, irq: 21, latency: 32, mmio: 
> 0xdc100000
> saa7133[0]: subsystem: 11bd:002f, board: Pinnacle PCTV 310i 
> [card=101,autodetected]
> saa7133[0]: board init: gpio is 600e000
> saa7133[0]: i2c eeprom read error (err=-5)
> tuner 2-004b: chip found @ 0x96 (saa7133[0])
> tuner 2-004b: setting tuner address to 61
> tuner 2-004b: type set to tda8290+75a
> saa7133[0]: registered device video0 [v4l2]
> saa7133[0]: registered device vbi0
> saa7133[0]: registered device radio0
> saa7134 ALSA driver for DMA sound loaded
> saa7133[0]/alsa: saa7133[0] at 0xdc100000 irq 21 registered as card -1
> 
> ----------END OF KERNEL MESSAGE --------------------
> 
> 9- modprobe saa7134-dvb
> 
> ----------KERNEL MESSAGES -------------------
> 
> DVB: registering new adapter (saa7133[0]).
> DVB: registering frontend 0 (Philips TDA10046H DVB-T)...
> 
> ----------END OF KERNEL MESSAGE -----------------
> 
> 10- scan it-Milano
> 
> 
> ----------KERNEL MESSAGES -------------------
> 
> tda1004x: setting up plls for 48MHz sampling clock
> tda1004x: found firmware revision 0 -- invalid
> 
> ----------END OF KERNEL MESSAGE -----------------
> 
> output of scan programs : many stations :P
> 
> 11- With kaffeine i try to rescan and view channels --> that's all ok!!
> 
> 12- Analog work without specify card=77 options! Tvtime shows channels 
> without problems!
> 
> Sorry for my long report but i think that all details in a testing 
> procedure are very important!
> Hope that's all is clear!!
> 
> Theres a remote....any chance to get it works??
> 
Kevin, did you gave a try to /dev/radio0?
Could you please try with kradio, or radio if it's tuning correctly?

I'll try the path on my debian this afternoon. (I hope so)

Cheers,

-- 

Emilio Castellano



More information about the linux-dvb mailing list