[linux-dvb] AverTV Hybrid+FM PCI

- gothmog.es at gmail.com
Tue Oct 10 08:48:18 CEST 2006


Hi, I recently got this new hybrid analog/dvb-t card from Avermedia and I'm
trying to get it to work, but I can't. There is a review in russian here:
http://www.hardwareportal.ru/Multimedia/Aver.hybridfmpci/index.html

Exact model: A16D

I've been reading several howto's on linuxt.org and other places but I can't
get to any point.

This card has the following relevant chips:

- SAA7135HL decoder
- MT352 demodulator
- XC3018ACQ tuner

AFAIK, all of them are supported, but no one card has them together. However
I don't know where start to merge these modules.

dmesg with saa7134 without parameters:

saa7130/34: v4l2 driver version 0.2.14 loaded
ACPI: PCI Interrupt 0000:00:0b.0[A] -> Link [LNKC] -> GSI 5 (level, low) ->
IRQ 5
saa7133[0]: found at 0000:00: 0b.0, rev: 209, irq: 5, latency: 32, mmio:
0xdf001000
saa7133[0]: subsystem: 1461:f936, board: UNKNOWN/GENERIC
[card=0,autodetected]
saa7133[0]: board init: gpio is effffff
saa7133[0]: i2c eeprom 00: 61 14 36 f9 00 00 00 00 00 00 00 00 00 00 00 00
saa7133[0]: i2c eeprom 10: ff ff ff ff ff 20 ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 20: 01 40 01 02 02 01 01 00 08 ff 00 0e ff ff ff ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 40: ff 65 00 ff c2 1e ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0

I've notice that if I pass card=46 to the card, I can execute
tvtime-scanner, although all tuners I've tried fail tuning analog channels.
If I pass card=85 to the card, it looks like if it loads fine dvb, but scan
(from dvbapps) fails always. I suppose again is a trouble with the tuner,
which I cannot identify correctly.

On both cases, I tried several (almost all of them) Philips tuners and tuner
71, with no result.

lspci:

00:0b.0 Multimedia controller: Philips Semiconductors SAA7133/SAA7135 Video
Broadcast Decoder (rev d1)

lspci nv:

00:0b.0 0480: 1131:7133 (rev d1)
Subsystem: 1461:f936
Flags: bus master, medium devsel, latency 32, IRQ 5
Memory at df001000 (32-bit, non-prefetchable) [size=2K]
Capabilities: [40] Power Management version 2

System is debian Etch - kernel 2.6.17-2-686
Software: tvtime and kdetv for analog tv; kaffeine for dvb-t

So, how can I start for getting this card working (analog or dvb, at least
one of them) ?

Thanks, and sorry about my poor english.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20061010/e46f4469/attachment-0001.htm


More information about the linux-dvb mailing list