[linux-dvb] mplayer "TUNING FAILED", only first time per channel

Klaus Frahm frahm at irsamc.ups-tlse.fr
Mon Oct 16 22:38:04 CEST 2006


Simon Detheridge wrote:
> Hi,
> 
> On my system, mplayer sometimes (but not always) requires two attempts to
> tune into a dvb channel when launched with a dvb:// url. (For example,
> 'mplayer "dvb://BBC ONE"' -- The first time, it comes up with "TUNING
> FAILED", but the second time it almost invariably works fine.

I had a similar problem with my AverTV A800 DVB-T-tuner, i.e. after 
getting the first lock I had to clic on stop and then on play (with VLC) 
to start the video flux. This is still okay when looking TV on the 
screen but not when one wants to record a program this is big problem. 
Therefore I used as a work around a small script like:

tzap -r M6 -x -S
vlc (all dvb-options)

here tzap gets the first lock and then quits due to the option "-x" and 
then afterwards the second lock obtained in VLC works (with DVB-S it's 
szap etc.).

> 
> My guess is it takes my dvb card longer to tune than mplayer expects??
> 
> Anyway, this causes problems for freevo and suchlike which fire up mplayer
> to do things like view and record TV.
> 
> I'm currently running mplayer with a wrapper script that relaunches it
> with the same parameters if it greps "TUNING FAILED" in sterr, but
> obviously this is very ungraceful and is probably going to break other
> things.
> 
> Is there a way to make this problem go away? Perhaps a --be-persistent
> flag? Or... ?
> 

I don't know if you have the same problem (this may depend on your 
DVB-card) but my problem disappeard with the v4l-driver from the kernel 
version 2.6.18 and the with latest driver from the official v4l-tree. 
Maybe un update to the latest driver may solve your problem ? Otherwise 
try a workaround using tzap (ou szap, ...).




More information about the linux-dvb mailing list