[linux-dvb] Twinhan cab-ci problem in Fedora Core 5

Raido raidoz at hot.ee
Sun Sep 3 20:47:15 CEST 2006


For the never driver the currently necessary hack works like this:

"in dst.c line 1360

!(state->dst_type == DST_TYPE_IS_CABLE) &&

comment out that line and see whether you are getting any further."


Though I don't think it will help with your particular problem. Could 
there be some kind of conflict with your Terratec card?

If you get it up and running, let me know how it works, especially if 
you have encrypted channels and a CAM.


Svante Järvstråt wrote:
> I have a Twinyan cab-ci DVB-C card (VP 2031A) that I have been trying to
> get to work with fedora core 5 without success.
> In the system I also have a Terratec Cinergy 400 card.
>
> The problem seems to be that no frontend is found:
> ---
> dmesg:
> ...
> audit(1154641790.800:2): selinux=0 auid=4294967295
> Linux video capture interface: v1.00
> bttv: driver version 0.9.16 loaded
> bttv: using 8 buffers with 2080k (520 pages) each for capture
> bttv: Bt8xx card found (0).
> ACPI: PCI Interrupt 0000:00:0a.0[A] -> GSI 18 (level, low) -> IRQ 169
> bttv0: Bt878 (rev 17) at 0000:00:0a.0, irq: 169, latency: 32, mmio:
> 0xcfcfe000
> bttv0: detected: Twinhan VisionPlus DVB [card=113], PCI subsystem ID is
> 1822:0001
> bttv0: using: Twinhan DST + clones [card=113,autodetected]
> bttv0: gpio: en=00000000, out=00000000 in=00fb05fd [init]
> input: i2c IR (Hauppauge) as /class/input/input2
> ir-kbd-i2c: i2c IR (Hauppauge) detected at i2c-0/0-001a/ir0 [bt878 #0
> [hw]]
> bttv0: using tuner=4
> saa7130/34: v4l2 driver version 0.2.14 loaded
> bttv0: add subdevice "dvb0"
> ACPI: PCI Interrupt 0000:00:0c.0[A] -> GSI 16 (level, low) -> IRQ 177
> saa7134[0]: found at 0000:00:0c.0, rev: 1, irq: 177, latency: 32, mmio:
> 0xcfffbc00
> saa7134[0]: subsystem: 153b:1142, board: Terratec Cinergy 400 TV
> [card=8,autodetected]
> saa7134[0]: board init: gpio is 5000a
> input: saa7134 IR (Terratec Cinergy 40 as /class/input/input3
> bt878: AUDIO driver version 0.0.0 loaded
> tuner 1-0060: All bytes are equal. It is not a TEA5767
> tuner 1-0060: chip found @ 0xc0 (saa7134[0])
> tuner 1-0060: type set to 5 (Philips PAL_BG (FI1216 and compatibles))
> ...
> bt878: Bt878 AUDIO function found (0).
> ACPI: PCI Interrupt 0000:00:0a.1[A] -> GSI 18 (level, low) -> IRQ 169
> bt878_probe: card id=[0x11822],[ Twinhan VisionPlus DVB ] has DVB
> functions.
> bt878(0): Bt878 (rev 17) at 00:0a.1, irq: 169, latency: 32, memory:
> 0xcfcff000
> ...
> DVB: registering new adapter (bttv0).
> rdc_8820_reset: Resetting DST
> dst_gpio_outb: mask=[0004], enbb=[0004], outhigh=[0000]
> dst_gpio_outb: mask=[0004], enbb=[0004], outhigh=[0004]
> dst_comm_init: Initializing DST.
> dst_gpio_outb: mask=[ffffffff], enbb=[0001], outhigh=[0000]
> rdc_reset_state: Resetting state machine
> dst_gpio_outb: mask=[0002], enbb=[0002], outhigh=[0000]
> dst_gpio_outb: mask=[0002], enbb=[0002], outhigh=[0002]
> i2c IR (Hauppauge): unknown key: key=0x3f raw=0x3fff down=1
> writing [ 00 06 00 00 00 00 00 fa ]
> write_dst: _write_dst error (err == -5, len == 0x08, b0 == 0x00)
> dst_error_recovery: Trying to return from previous errors.
> dst_gpio_outb: mask=[ffffffff], enbb=[0000], outhigh=[0000]
> dst_gpio_outb: mask=[ffffffff], enbb=[0001], outhigh=[0000]
> write_dst: _write_dst error (err == -5, len == 0x08, b0 == 0x00)
> dst_error_recovery: Trying to return from previous errors.
> dst_gpio_outb: mask=[ffffffff], enbb=[0000], outhigh=[0000]
> dst_gpio_outb: mask=[ffffffff], enbb=[0001], outhigh=[0000]
> write_dst: RDC 8820 RESET
> dst_error_bailout: Trying to bailout from previous error.
> rdc_8820_reset: Resetting DST
> dst_gpio_outb: mask=[0004], enbb=[0004], outhigh=[0000]
> dst_gpio_outb: mask=[0004], enbb=[0004], outhigh=[0004]
> dst_gpio_outb: mask=[ffffffff], enbb=[0000], outhigh=[0000]
> dst_probe: unknown device.
> frontend_init: Could not find a Twinhan DST.
> dvb-bt8xx: A frontend driver was not found for device 109e/0878
> subsystem 1822/0001
> ---
> in the /dev/dvb/adapter0 directory, the frontend device is missing. 
> The card works fine under fedora core 4, using a slightly hacked driver.
> I had to change to the following line in the dst driver to get it to
> work properly:
> ---
> .type_flags = DST_TYPE_HAS_NEWTUNE | DST_TYPE_HAS_FW_2 
> ---
> I have tried something similar on FC5 (DST_TYPE_HAS_NEWTUNE_2 |
> DST_TYPE_HAS_FW_2) without success.
>
> Any hints on what might be wrong would be highly appreciated. I have
> been trying to upgrade the system to FC5 since april, so far without
> success.
>
> BR
> /Svante
>
>
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
>   




More information about the linux-dvb mailing list