[linux-dvb] Compro Videomate DVB-T200 and friends

Michael Krufky mkrufky at linuxtv.org
Thu Sep 7 22:43:28 CEST 2006


James Fidell wrote:
> [I'm a DVB newbie, so feel free to refer me to documentation if that's
> the appropriate answer.]
> 
> I have a box that I'm planning to use as a MythTV backend, with a Compro
> Videomate DVB-T200 and two Xpert V-Stream TV-PVR 883 cards.  I've tried
> and failed with Centos 4.4 and I'm currently using Fedora Core 5 with a
> 2.6.17 kernel.
> 
> The first issue is that the DVB-T200 card is recognised, but I'm not
> sure the card definition in the saa7134 code is correct.  It lists the
> DVB-T200 as having a composite and S-Video input only with no tuner,
> whereas mine has composite, S-Video and Analogue/Digital TV inputs and
> a tuner.  I'm wondering if there should be three separate definitions
> and card IDs for the DVB-T200, DVB-T200A and DVB-T220 (which may be the
> one that actually does match the DVB-T200 definition in the code).  Can
> anyone help me with this?  Compro have some information on each of the
> cards here:

The "No Tuner" in the v4l struct only means that the tuner is not set up
to receive analog broadcasts.  It should, however, work for DVB.

Are you sure this card can receive analog television broadcasts?  If so,
then you should try to specify the tuner # to the saa7134 module by
adding a line to your modprobe.conf:

options saa7134 tuner=XX

where XX should be replaced by the tuner ID found in
linux/Documentation/video4linux/CARDLIST.tuner

> Second, the TV-PVR 883 cards aren't recognised, but the manual pretty
> much states they're a KWorld LTV883RF, so I've used card=16 as a
> parameter for the cx88xx module.

Does this work properly for you?  If so, then we can alter the driver so
that this card will be autodetected.  Please respond with the PCI
subsystem ID of that card.  Preferably, I'd like to see the relevant
portions of your dmesg output.

> Finally (for the moment :) I was expecting "something" (udev/v4l/etc.)
> to create some /dev/dvb/* devices, but that hasn't happened.  Am I
> mistaken, or missing something?  How should these devices come into
> being?  I see that linuxtv-dvb-apps-1.1.1 uses these device names.  Is
> that the right version I should be using?

The saa7134-dvb module does not autoload :-(  do:

modprobe saa7134-dvb

voila!
> 
> Thanks,
> James

HTH,

Michael Krufky




More information about the linux-dvb mailing list