[Re: [linux-dvb] Compro Videomate DVB-T200 and friends

James Fidell james at fidell.co.uk
Mon Sep 11 12:09:20 CEST 2006


Hartmut Hackmann wrote:

> The only explaination i have is that your module dependency file is
> broken. To verify this, may i ask you to examine the kernel log file
> (/var/log/messages) carefully again? There should be messages about
> missing symbols.
> You should rerun "depmod". If this fails, your kernel is not properly
> installed.
> You are right, the option "oss=1" is useless for a dvb card.

I think I may re-install the OS from scratch to make sure everything is
clean.

> Regarding the available channels: You should check the firmware revision
> of the channel decoder (again in the kernel log). I guess it is 2.0
> The recent version is 2.9 and has significantly improved regarding poor
> signal quality.
> You can obtain it i.e. from lifeview with the get_dvb_firmware.pl script
> in our repository.

I have the firmware dvb-fe-tda10046.fw downloaded.  I assume that's the
correct one from what I've been told previously.  I don't understand the
mechanism by which it is supposed to get uploaded to the card though.
>From the wiki I understand that there's some udev/hotplug magic that is
supposed to happen, but I'm not sure it does.

>From dmesg I have:

tda1004x: setting up plls for 53MHz sampling clock
tda1004x: found firmware revision 26 -- ok

Should other messages be logged when the firmware is updated?

James



More information about the linux-dvb mailing list