[linux-dvb] MSI DigiVOX mini II

Aapo Tahkola aet at rasterburn.org
Wed Apr 11 23:18:31 CEST 2007


On Wed, 11 Apr 2007 22:14:34 +0200
"Jan Kuenstler" <jan.kuenstler at web.de> wrote:

> Hi all,
> I am new to the list and new to dvb-t in general. I bought an MSI
> DigiVOX mini II.
> 
> I searched the archive and found a an interesting part:
> http://www.mail-archive.com/linux-dvb@linuxtv.org/msg21893.html
> 
> I used the firmware attached to the first post and compiled latest
> from source:
> http://linuxtv.org/hg/~aapot/m920x?ca=2bfda2098748;type=bz2
> 
> Now dmesg shows:
> ================
> usb 1-2: new high speed USB device using ehci_hcd and address 32
> usb 1-2: configuration #1 chosen from 1 choice
> dvb-usb: found a 'MSI DIGI VOX mini II DVB-T USB2.0' in cold state,
> will try to load a firmware
> dvb-usb: downloading firmware from file 'dvb-usb-digivox-02.fw'
> usb 1-2: USB disconnect, address 32
> usb 1-2: new high speed USB device using ehci_hcd and address 33
> usb 1-2: configuration #1 chosen from 1 choice
> dvb-usb: found a 'MSI DIGI VOX mini II DVB-T USB2.0' in warm state.
> i2c_adapter i2c-4: SMBus Quick command not supported, can't probe for
> chips dvb-usb: will pass the complete MPEG2 transport stream to the
> software demuxer. DVB: registering new adapter (MSI DIGI VOX mini II
> DVB-T USB2.0). DVB: registering frontend 0 (Philips TDA10046H
> DVB-T)... dvb-usb: MSI DIGI VOX mini II DVB-T USB2.0 successfully
> initialized and connected.
> 
> kaffeine works fine, beside the sound. I have (all ~30 channels) no
> sound. Then I discovered one channel (ProSieben) where i can switch
> from "306(deu)" to "312(ac3)". Now in ac3-mode sound works. The
> problem is: It is the only channel where I get this option from
> kaffeine.
> 
> Mplayer (compiled with support for v4l, v4l2 and dvb) cannot play at
> all: ==================
> Playing dvb://.
> dvb_tune Freq: 474000
> dvb_streaming_read, attempt N. 6 failed with errno 0 when reading
> 2048 bytes dvb_streaming_read, attempt N. 5 failed with errno 0 when
> reading 1108 bytes TS file format detected.
> =OR===============
> Playing dvb://.
> dvb_tune Freq: 474000
> dvb_streaming_read, attempt N. 6 failed with errno 0 when reading
> 2048 bytes dvb_streaming_read, attempt N. 5 failed with errno 0 when
> reading 2048 bytes dvb_streaming_read, attempt N. 4 failed with errno
> 0 when reading 2048 bytes dvb_streaming_read, attempt N. 3 failed
> with errno 0 when reading 2048 bytes dvb_streaming_read, attempt N. 2
> failed with errno 0 when reading 2048 bytes dvb_streaming_read,
> attempt N. 1 failed with errno 0 when reading 2048 bytes
> dvb_streaming_read, return 0 bytes
> 
> Exiting... (End of file)
> 
> Xine failed to play with (in endless retries):
> ===================
> input_dvb: ERROR: Trying to get lock...
> 
> 
> I am fine to use kaffeine, but does someone know how to fix this ?
> Is it really a problem with kaffeine ?

At least on Ubuntu, Kaffeine and xine both need xine-extracodecs
installed due to legal issues.

> Does someone have a new/better firmware version ? Where does the fw
> came from ?

DVB just transmits data, you probably would get no picture if something
at driver level were bad. Buggy hw pid filtering could cause something
like that...

You can disable hardware pid filtering by commenting lines 704-709 of
m920x.c . Let me know if this helps with any of the problems you've had.

-- 
Aapo Tahkola



More information about the linux-dvb mailing list