[linux-dvb] High number of uncorrected blocks with TT-C1500 and QAM256

Per Dalén perda at oden.cnwab.se
Thu Apr 12 19:24:51 CEST 2007


Hello,

I have had similar experience like You with the same card (TT DVB C1500) 
regarding QAM64. I discovered that there had been a successful fix for 
this done for QAM128 by changing the sweeprate, see 
http://www.linuxtv.org/pipermail/linux-dvb/2006-February/008439.html
So I made some test to find a working sweeprate for QAM64, see 
http://www.linuxtv.org/pipermail/linux-dvb/2006-May/010141.html

You might have to the same trip for QAM256?

Look at line 419 in stv0297.c, 
http://linuxtv.org/hg/v4l-dvb?f=e399629b4743;file=linux/drivers/media/dvb/frontends/stv0297.c;style=gitweb


Suggestion:

--- stv0297.c.orig      2007-04-12 19:18:48.000000000 +0200
+++ stv0297.c   2007-04-12 19:20:06.000000000 +0200
@@ -404,10 +404,13 @@
                 break;

         case QAM_128:
-       case QAM_256:
                 delay = 200;
                 sweeprate = 500;
                 break;
+       case QAM_256:
+               delay = 200;
+               sweeprate = YOUR_SWEEPRATE;
+               break;

         default:
                 return -EINVAL;


best of luck
Per Dalén

Petri Helin wrote:
> Hi,
> 
> I am not completely sure if this really is connected to the channel
> using QAM256, but that's what I suspect. I use Technotrend's TT-C1500
> budget card with appropriate common interface and Conax CAM. This
> combination works flawlessly on every channel which uses QAM64 or
> QAM128. Now the Finnish cable company, for which I am subscribed to,
> started broadcasting Canal+ Film HD some three months ago. This has
> worked otherwise quite well, but I get constant disturbances/artifacts
> in the picture. I used to think that it was just because the bit rate
> was five times the normal (17 Mbit/s compared to 3-4 Mbit/s).
> 
> But couple of days ago I noticed that this channel is actually the
> only one I am receiving that uses QAM256. Searching the Internet
> provided me with couple of forum threads/mailing list posts that
> suggested that certain DVB-C cards might have problems in receiving
> QAM256 modulated broadcast, but the hits were mainly on VDRportal and
> in German and I might have lost something in the translation... In
> addition to the picture getting garbled every now and then I can
> notice the problem also from the high values of UNC (uncorrected
> blocks) and BER (bit error rate). On Canal+ Film HD UNC is between 0
> and 20 and BER is about 250. On all other channels UNC is 0 and BER
> close to 0. STR ja SNR are the same on all channels, including Canal+
> Film HD.
> 
> Now what I am asking is for any experiences using DVB-C cards to
> receive QAM256 modulated broadcasts, no matter if HDTV or not.
> 
> -Petri
> 
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb




More information about the linux-dvb mailing list