[linux-dvb] modprobe mantis stalls/hangs/freezes (Twinhan VP-1034 and ivtv)

Michel Verbraak michel at verbraak.org
Sat Aug 25 18:02:14 CEST 2007


I have a Twinhan VP-1034 and I use the the latest hg, today, and 
http://jusst.de/manu/mantis-v4l-dvb.tar.bz2 with kernel 2.6.22.1.

When I do a 'modprobe mantis' my prompt never returns. The machine still 
is working.

Following is in my log with option verbose=255 for mantis module:

Aug 25 17:53:32 recorder kernel: ACPI: PCI Interrupt 0000:02:09.0[A] -> 
GSI 21 (level, low) -> IRQ 22
Aug 25 17:53:32 recorder kernel:
Aug 25 17:53:32 recorder kernel: gpif status: 6000  irqcfg: 0000
Aug 25 17:53:32 recorder kernel: mantis_set_direction (0): TS direction 
setup
Aug 25 17:53:32 recorder kernel: irq: 22, latency: 64
Aug 25 17:53:32 recorder kernel:  memory: 0xf7eff000, mmio: 0xf88fe000
Aug 25 17:53:32 recorder kernel: found a VP-1034 PCI DVB-S/DSS device on 
(02:09.0),
Aug 25 17:53:32 recorder kernel:     Mantis Rev 1 [1822:0014], irq: 22, 
latency: 64
Aug 25 17:53:32 recorder kernel:     memory: 0xf7eff000, mmio: 0xf88fe000
Aug 25 17:53:32 recorder kernel:         mantis_i2c_write: 
Address=[0x25] <W>[ ]
Aug 25 17:53:33 recorder kernel:         mantis_i2c_write: 
Address=[0x25] <W>[ 00 <3>mantis_ack_wait (0): Waiting for Slave RACK
Aug 25 17:53:33 recorder kernel: mantis_ack_wait (0): Waiting for Slave RACK
Aug 25 17:53:42 recorder last message repeated 499 times
Aug 25 17:53:42 recorder kernel: mantis_ack_wait (0): Slave RACK Fail !
Aug 25 17:53:42 recorder kernel: mantis_i2c_write (0): ACK failed<W>

I must say I also have a Hauppauge PVR-150 and a PVR-350 in this 
machine, using ivtv from hg, and when I remove both I do not have this 
problem. The modules load without any problems.

If more verbose messages are needed from othe modules please let me 
know. I do not have this problem with kernel versions 2.6.20 and below. 
Something changed in 2.6.21 and I do not know what.




More information about the linux-dvb mailing list