[linux-dvb] avermedia e506r mixed success

mimo mimo at restoel.net
Fri Aug 31 01:20:29 CEST 2007


Hi

so I have patched my kernel and compiled qemu with pciproxy patches. I've put 
the commands I've used on the linux tv wiki 
http://linuxtv.org/v4lwiki/index.php/Qemu

And then, finally, after days of compiling, patching, downloading, etc this is 
what happened:

sudo qemu -hda /data/tmp/winxp.img -pciproxy 02:07.0
Password:
Warning: No DNS servers found
Could not open '/dev/qvm86' - QEMU acceleration layer not activated
Adding PCI Host Proxy device: 02:07:0
02:07.0: Host device can't be allowed to share an IRQ yet, sorry, interrupts 
disabled.

after I re-insert the wlan card lspci shows

00:00.0 Host bridge: Intel Corporation 82830 830 Chipset Host Bridge (rev 02)
00:01.0 PCI bridge: Intel Corporation 82830 830 Chipset AGP Bridge (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801CA/CAM USB (Hub #1) (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801CA/CAM USB (Hub #2) (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 41)
00:1f.0 ISA bridge: Intel Corporation 82801CAM ISA Bridge (LPC) (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801CAM IDE U100 (rev 01)
00:1f.3 SMBus: Intel Corporation 82801CA/CAM SMBus Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corporation 82801CA/CAM AC'97 Audio 
Controller (rev 01)
00:1f.6 Modem: Intel Corporation 82801CA/CAM AC'97 Modem Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY
02:02.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 
Controller (PHY/Link)
02:04.0 Ethernet controller: Realtek Semiconductor Co., Ltd. 
RTL-8139/8139C/8139C+ (rev 10)
02:07.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 88)
02:07.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 88)
02:07.2 System peripheral: Ricoh Co Ltd R5C576 SD Bus Host Adapter
03:00.0 Multimedia controller: Philips Semiconductors SAA7133/SAA7135 Video 
Broadcast Decoder (rev d1)
07:00.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless 
LAN Controller (rev 03)

hmmm......



On Monday 28 May 2007 23:04:44 mimo wrote:
> Hi Markus
>
>
> I had a look at qemu and the pci proxy stuff. Is there any point in me
> trying to get that to work and dump something that would be useful? We
> have DVB-T here but I think there might be issues as the card is on a
> shared IRQ but I could probably just unplug the wireless card while I'm
> dumping info. Let me know if that would be of any help - maybe there's
> stuff I could figure out myself but I don't have any experience with this
> stuff just can read/write C that's all!
>
> Thanks,
>
> mimo
>
> > On 5/27/07, mimo <mimo at restoel.net> wrote:
> >> Hi
> >>
> >> I have had some success and failure with this card - it identifies as
> >> 1131:7133 using latest mercurial stuff.
> >> I have added
> >> options saa7134 card=117 alsa=1
> >> install saa7134 /sbin/modprobe xc3028-tuner; /sbin/modprobe
> >> --ignore-install
> >> saa7134; /sbin/modprobe saa7134-dvb; /sbin/modprobe saa7134-alsa
> >>
> >> Using firmware_pinnacle.tgz the whole analog part of the card works
> >> (kernel
> >> 2.6.20-lowlatency from ubuntu).
> >>
> >> Below is my dmsg. The audio works with the sox workaround. DVB-T
> >> doesn't. I
> >> also tried card=85
> >> (http://www.linuxtv.org/pipermail/linux-dvb/2006-May/010246.html) but
> >> that
> >> reported problems.
> >>
> >> What are the chances of getting dvb-t working and can I help in some
> >> way?
> >
> > the chances are 50:50, I guess there are just some very small changes
> > missing to get DVB-T work properly. Since I do not have that device I
> > cannot do anything and someone else has to figure out the outstanding
> > part.
> >
> > Maybe someone who owns that device in Berlin/Leipzig/(Dresden would be
> > fine in around 1 month when they start to broadcast DVB-T) can contact
> > me
> > I cannot guarantee that I can get it work, chances aren't too bad
> > since I got analogue TV (including audio) and radio already work.
> >
> > Markus
> >
> >> Thanks,
> >>
> >> mm
> >>
> >> [12987.596000] pccard: CardBus card inserted into slot 0
> >> [12987.767000] saa7130/34: v4l2 driver version 0.2.14 loaded
> >> [12987.769000] PCI: Enabling device 0000:03:00.0 (0000 -> 0002)
> >> [12987.769000] ACPI: PCI Interrupt 0000:03:00.0[A] -> Link [LNKA] -> GSI
> >> 11
> >> (level, low) -> IRQ 11
> >> [12987.770000] saa7133[0]: found at 0000:03:00.0, rev: 209, irq: 11,
> >> latency:
> >> 0, mmio: 0x3c000000
> >> [12987.770000] PCI: Setting latency timer of device 0000:03:00.0 to 64
> >> [12987.770000] saa7133[0]: subsystem: 1461:f436, board: AVerMedia
> >> Cardbus
> >> TV/Radio (E506R) [card=117,insmod option]
> >> [12987.770000] saa7133[0]: board init: gpio is 2220000
> >> [12987.897000] saa7133[0]: i2c eeprom 00: 61 14 36 f4 00 00 00 00 00 00
> >> 00
> >> 00
> >> 00 00 00 00
> >> [12987.897000] saa7133[0]: i2c eeprom 10: 00 ff e2 0e ff 20 ff ff ff ff
> >> ff
> >> ff
> >> ff ff ff ff
> >> [12987.897000] saa7133[0]: i2c eeprom 20: 01 40 01 02 02 01 01 03 08 ff
> >> 00
> >> ff
> >> ff ff ff ff
> >> [12987.898000] saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff
> >> ff
> >> ff
> >> ff ff ff ff
> >> [12987.898000] saa7133[0]: i2c eeprom 40: ff 65 00 ff c2 1e ff ff ff ff
> >> ff
> >> ff
> >> ff ff ff ff
> >> [12987.899000] saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff
> >> ff
> >> ff
> >> ff ff ff ff
> >> [12987.899000] saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff
> >> ff
> >> ff
> >> ff ff ff ff
> >> [12987.899000] saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff
> >> ff
> >> ff
> >> ff ff ff ff
> >> [12988.002000] tuner 0-0061: chip found @ 0xc2 (saa7133[0])
> >> [12988.002000]
> >> /home/mimo/e506/v4l-dvb-experimental-20070523/v4l/tuner-core.c:
> >> setting tuner callback
> >> [12988.002000] tuner 0x61: Configuration acknowledged
> >> [12988.002000]
> >> /home/mimo/e506/v4l-dvb-experimental-20070523/v4l/tuner-core.c:
> >> setting tuner callback
> >> [12988.002000] tuner 0x61: Configuration acknowledged
> >> [12988.002000]
> >> /home/mimo/e506/v4l-dvb-experimental-20070523/v4l/tuner-core.c:
> >> setting tuner callback
> >> [12988.049000]
> >> /home/mimo/e506/v4l-dvb-experimental-20070523/v4l/xc3028-tuner.c:
> >> attach request!
> >> [12988.049000]
> >> /home/mimo/e506/v4l-dvb-experimental-20070523/v4l/tuner-core.c:
> >> xc3028 tuner successfully loaded
> >> [12988.074000] saa7133[0]: registered device video0 [v4l2]
> >> [12988.075000] saa7133[0]: registered device vbi0
> >> [12988.075000] saa7133[0]: registered device radio0
> >> [12988.080000] saa7134 ALSA driver for DMA sound loaded
> >> [12988.080000] saa7133[0]/alsa: saa7133[0] at 0x3c000000 irq 11
> >> registered
> >> as
> >> card -1
> >>
> >> _______________________________________________
> >> linux-dvb mailing list
> >> linux-dvb at linuxtv.org
> >> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
> >
> > --
> > Markus Rechberger
>
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb



More information about the linux-dvb mailing list