[linux-dvb] KNC1 DVB-C cam module not working on driver load

Jeroen Asselman jeroen at asselman.com
Sat Feb 3 15:53:30 CET 2007


Hi,

Is it OK to re-post the question/problem below? As google doesn't  
really help me.


Op 8-jan-2007, om 20:46 heeft Jeroen Asselman het volgende geschreven:

> Hello,
>
> I have a small problem with the cam feature of the KNC1 DVB-C card.  
> When I have the cam module inserted and then load the budget-av  
> module (for example during system boot). The cam module doesn't  
> initialize correctly. This is what my dmesg shows when I do  
> "modprobe budget-av"
>
> saa7146: register extension 'budget_av'.
> ACPI: PCI Interrupt 0000:04:07.0[A] -> Link [LNKB] -> GSI 17  
> (level, low) -> IRQ 90
> saa7146: found saa7146 @ mem ffffc2000019ec00 (revision 1, irq 90)  
> (0x1894,0x0020).
> saa7146 (0): dma buffer size 192512
> DVB: registering new adapter (KNC1 DVB-C).
> adapter failed MAC signature check
> encoded MAC from EEPROM was  
> ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff
> KNC1-0: MAC addr = 00:09:d6:6d:5a:f0
> DVB: registering frontend 0 (Philips TDA10021 DVB-C)...
> budget-av: ci interface initialised.
> budget-av: cam inserted A
>
> and after some time:
>
> dvb_ca adaptor 0: PC card did not respond :(
>
>
> If I then manually remove the alphacrypt cam from the CI interface  
> and reinsert I get the following messages in my dmesg log:
>
> budget-av: cam ejected 5
> budget-av: cam inserted B
> dvb_ca adapter 0: DVB CAM detected and initialised successfully
>
> After which I can succesfully use the card and watch encrypted  
> channels.
>
> What can I do to make sure this will also work immedialy when the  
> system boots?

- Jeroen

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 2151 bytes
Desc: not available
Url : http://www.linuxtv.org/pipermail/linux-dvb/attachments/20070203/e0863d43/smime-0001.bin


More information about the linux-dvb mailing list