[linux-dvb] How do you know CAM is recognized ?

Jeroen Asselman jeroen at asselman.com
Mon Feb 12 08:17:38 CET 2007


Op zondag 11-02-2007 om 10:14 uur [tijdzone +0100], schreef Kristof
Pelckmans:
> Yesterday I went to a shop and was able to see that my Alphacrypt is 
> working well. I think my Technotrend card is not seeing the CAM. Do I 
> have to add extra load parameters to the module or load extra modules ?
> 
> ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------
> lsmod
> Module                  Size  Used by
> af_packet              13064  2
> snd_pcm_oss            36640  0
> snd_mixer_oss          14464  1 snd_pcm_oss
> rtc                    10548  0
> parport_pc             23588  1
> lp                      9604  0
> parport                33736  2 parport_pc,lp
> stv0297                 6784  1
> ide_cd                 34720  0
> cdrom                  34720  1 ide_cd
> tuner                  60200  0
> snd_hda_intel          15896  5
> snd_hda_codec         158720  1 snd_hda_intel
> dvb_ttpci              96868  16
> snd_pcm                61700  4 snd_pcm_oss,snd_hda_intel,snd_hda_codec
> saa7134               114528  0
> snd_timer              18692  2 snd_pcm
> snd                    43748  14 
> snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_hda_codec,snd_pcm,snd_timer
> compat_ioctl32          1280  1 saa7134
> soundcore               6624  1 snd
> dvb_core               70568  1 dvb_ttpci
> ir_kbd_i2c              6928  1 saa7134
> i2c_viapro              7956  0
> saa7146_vv             44288  1 dvb_ttpci
> snd_page_alloc          7944  2 snd_hda_intel,snd_pcm
> video_buf              20228  2 saa7134,saa7146_vv
> saa7146                15112  2 dvb_ttpci,saa7146_vv
> ttpci_eeprom            2304  1 dvb_ttpci
> ir_common              29828  2 saa7134,ir_kbd_i2c
> via_agp                 8320  1
> videodev               26112  2 saa7134,saa7146_vv
> v4l2_common            22144  4 tuner,saa7134,saa7146_vv,videodev
> i2c_core               17792  7 
> stv0297,tuner,dvb_ttpci,saa7134,ir_kbd_i2c,i2c_viapro,ttpci_eeprom
> agpgart                26444  1 via_agp
> v4l1_compat            14724  3 saa7134,saa7146_vv,videodev
> evdev                   8320  1

> <snip> 

> 00:0b.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
>         Subsystem: Technotrend Systemtechnik GmbH Octal/Technotrend 
> DVB-C for iTV
>         Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- 
> ParErr- Stepping- SERR- FastB2B-
>         Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- 
> <TAbort- <MAbort- >SERR- <PERR-
>         Latency: 32 (3750ns min, 9500ns max)
>         Interrupt: pin A routed to IRQ 22
>         Region 0: Memory at febff400 (32-bit, non-prefetchable) [size=512]
> <snip>
> VDR does not mention my CAM :

I don't see a module budget-av loaded? 

If you do a modprobe budget-av and check your "dmesg" log and perhaps
you see a:
"dvb_ca adaptor 0: PC card did not respond :("

If you see that message try to eject and reinsert the cam module after a
few seconds, perhaps you see a 
"dvb_ca adapter 0: DVB CAM detected and initialised successfully"
afterwards in your dmesg.


- Jeroen




More information about the linux-dvb mailing list