[linux-dvb] Problem getting Compro DVB-T300 to work

micah micah at bigpond.net.au
Mon Feb 19 11:02:12 CET 2007


Hartmut Hackmann wrote:
> Please continue testing with the driver from my personal repository for
> the time being.
> Are you sure you unloaded all modules before you tried the new drivers?
>
> There is one known issue with this card: The the tuner module
> *must not* be loaded before the saa7134 module, otherwise no tuner will
> be found, only the IF chip. This is what i see from your log.
>
> So please try the following:
> - install the drivers ("make install" as root)
> - remove all video related modules or better: reboot
> - do a "modprobe saa7134", nothing else.
>
> Does it work now?
>
> Best regards
>   Hartmut
>
Hello Hartmut and thanks for your help :-)

The driver was being loaded automatically at boot , so i made a file in 
/etc/hotplug/blacklist.d with saa7134 tuner and saa7134-dvb in it.
Then i rebooted and checked with lsmod - no saa or v4l modules loaded - 
good.
I saved the output of lsmod so i could see which modules would be loaded,
Then i did a "modprobe saa7134" as you suggested but i got the same result:

Linux video capture interface: v2.00
saa7130/34: v4l2 driver version 0.2.14 loaded
ACPI: PCI Interrupt Link [APC3] enabled at IRQ 18
ACPI: PCI Interrupt 0000:02:06.0[A] -> Link [APC3] -> GSI 18 (level, 
low) -> IRQ 18
saa7134[0]: found at 0000:02:06.0, rev: 1, irq: 18, latency: 32, mmio: 
0xfddff000
saa7134[0]: subsystem: 185b:c900, board: Compro Videomate DVB-T300 
[card=70,autodetected]
saa7134[0]: board init: gpio is 843f00
input: saa7134 IR (Compro Videomate DV as /class/input/input5
saa7134[0]: i2c eeprom 00: 5b 18 00 c9 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7134[0]: i2c eeprom 10: 00 ff 86 0f ff 20 ff ff ff ff ff ff ff ff ff ff
saa7134[0]: i2c eeprom 20: 01 40 01 03 03 ff 03 01 08 ff 00 87 ff ff ff ff
saa7134[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7134[0]: i2c eeprom 40: ff 02 00 c2 86 10 ff ff ff ff ff ff ff ff ff ff
saa7134[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff cb
saa7134[0]: i2c eeprom 60: 34 ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7134[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
tuner 2-0043: chip found @ 0x86 (saa7134[0])
tda9887 2-0043: tda988[5/6/7] found @ 0x43 (tuner)
tuner 2-0068: chip found @ 0xd0 (saa7134[0])
saa7134[0]: registered device video0 [v4l2]
saa7134[0]: registered device vbi0
saa7134[0]: frontend initialization failed

These are the modules loaded by typing that one command:

Module                  Size  Used by
saa7134_dvb            17228  0
dvb_pll                16132  1 saa7134_dvb
video_buf_dvb           7236  1 saa7134_dvb
dvb_core               84912  1 video_buf_dvb
tda1004x               15748  1 saa7134_dvb
firmware_class         11520  2 saa7134_dvb,tda1004x
tuner                  62312  0
saa7134               136276  1 saa7134_dvb
video_buf              27140  3 saa7134_dvb,video_buf_dvb,saa7134
compat_ioctl32          8896  1 saa7134
ir_kbd_i2c             10128  1 saa7134
ir_common              37316  2 saa7134,ir_kbd_i2c
videodev               27776  1 saa7134
v4l2_common            18304  4 tuner,saa7134,compat_ioctl32,videodev
v4l1_compat            12164  2 saa7134,videodev

I hope this helps.

-Micah




More information about the linux-dvb mailing list