[linux-dvb] Problem with Kworld ATSC-110

Dwaine Garden dwainegarden at rogers.com
Mon Jan 8 05:05:21 CET 2007

Looks like the active connection is still on the digital RF connection.    I mistakenly left the antenna on the digital connection.

Does not look like it's switching.   Still testing though...


----- Original Message ----
From: John <jharitos at yahoo.com>
To: Michael Krufky <mkrufky at linuxtv.org>
Cc: Dwaine Garden <dwainegarden at rogers.com>; linux-dvb at linuxtv.org; Linux and Kernel Video <video4linux-list at redhat.com>
Sent: Sunday, January 7, 2007 10:27:50 PM
Subject: Re: [linux-dvb] Problem with Kworld ATSC-110

Thanks, I'd be happy to test it out. It's not working
for me but I want to make sure I did it right.

The links says the following.

static int nxt200x_set_pll_input(u8 *buf, int input)
-    if (input)
-        buf[3] |= 0x08;
-    else
-        buf[3] &= ~0x08;
+    buf[3] |= 0x08;
    return 0;

Does this mean remove the code that has the minus and
add the one with the plus so the resulting code is.

static int nxt200x_set_pll_input(u8 *buf, int input)
    buf[3] |= 0x08;
    return 0;

From there, make the changes then as root

cd /usr/src/uname -r
make M=drivers/media/video/saa7134

Take the resulting saa7134-dvb.ko and move it to the

All the other modules in the lib directory are
compressed so take the saa7134-dvb.ko and compress as

Did I do this correctly?

--- Michael Krufky <mkrufky at linuxtv.org> wrote:

> John wrote:
> > Thanks, I look forward to seeing if it works on
> your
> > system. I also tried it on a the latest livedvd
> > Knoppix distro and it diplayed the same behavior.
> > 
> > --- Dwaine Garden <dwainegarden at rogers.com> wrote:
> > 
> >> I'll do some testing too.  I have not tried both
> >> analog and digital on separate RF connections.
> I sent out test patches to address this very issue
> ages ago, but nobody has ever
> responded with any test results...
> The current code in the kernel will (or should)
> behave as follows:
> One RF is used for analog + digital cable (QAM256)
> The other RF is used for OTA VSB only.
> One of the patches in the link above should change
> the behavior to reflect the following:
> Analog will always use one RF, and digital,
> regardless of VSB or QAM, will use the other.
> At the time I wrote the email, I wasnt sure which
> patch was correct, so I provided two
> for testing.  One will work correctly, and the other
> will probably force all tuning to
> use the single RF no matter what.
> I do not have an ATSC110 to test this with, so it is
> up to you guys to test the patches
> that I am providing, and make the appropriate
> changes to them as necessary.
> >> I think this is the only hdtv card that does have
> >> two RF connections.
> Actually, the FusionHDTV3 Gold-Q also has two rf
> inputs, in addition to
> the ATI HDTV Wonder.
> I hope this information helps you... PLEASE respond
> with some feedback.
> Cheers,
> Mike Krufky

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20070107/fd0d579d/attachment.htm

More information about the linux-dvb mailing list