[linux-dvb] Hauppauge WinTV-NOVA-T-Stick tuner problem?

Juha Korhonen konsulaatti at gmail.com
Wed Jan 10 22:43:30 CET 2007


Hi, I tried to install my dvb-t stick into my linux but it does not work
correctly. I am getting the "mt2060 I2C read failed" error when watching the
TV with vdr.

I have a Gentoo and I tried this with 2.6.17 and 2.6.18 kernels:

** downloaded and installed the drivers
hg clone http://linuxtv.org/hg/~pb/v4l-dvb
cd v4l-dvb/v4l
make
make install

** downloaded and installed the firmware
cd /lib/firmware
wget
http://vaasa.wi-bw.tfh-wildau.de/~pboettch/home/files/dvb-usb-dib0700-01.fw

I plugged the stick and got this:

Jan 10 23:08:06 xxx usb 1-4: new high speed USB device using ehci_hcd and
address 7
Jan 10 23:08:06 xxx usb 1-4: configuration #1 chosen from 1 choice
Jan 10 23:08:06 xxx dvb-usb: found a 'Hauppauge Nova-T Stick' in cold state,
will try to load a firmware
Jan 10 23:08:06 xxx dvb-usb: downloading firmware from file '
dvb-usb-dib0700-01.fw'
Jan 10 23:08:06 xxx dib0700: firmware started successfully.
Jan 10 23:08:07 xxx dvb-usb: found a 'Hauppauge Nova-T Stick' in warm state.
Jan 10 23:08:07 xxx dvb-usb: will pass the complete MPEG2 transport stream
to the software demuxer.
Jan 10 23:08:07 xxx DVB: registering new adapter (Hauppauge Nova-T Stick).
Jan 10 23:08:07 xxx DVB: registering frontend 0 (DiBcom 7000PC)...
Jan 10 23:08:07 xxx DVB: Unable to find symbol mt2060_attach()
Jan 10 23:08:07 xxx dvb-usb: Hauppauge Nova-T Stick successfully initialized
and connected.

** the mt2060 module is not loaded...
modprobe mt2060

Then I unplugged and plugged the stick and the result was this:

Jan 10 23:08:38 xxx usb 1-4: USB disconnect, address 7
Jan 10 23:08:38 xxx dvb-usb: Hauppauge Nova-T Stick successfully
deinitialized and disconnected.
Jan 10 23:08:40 xxx usb 1-4: new high speed USB device using ehci_hcd and
address 8
Jan 10 23:08:41 xxx usb 1-4: configuration #1 chosen from 1 choice
Jan 10 23:08:41 xxx dvb-usb: found a 'Hauppauge Nova-T Stick' in cold state,
will try to load a firmware
Jan 10 23:08:41 xxx dvb-usb: downloading firmware from file '
dvb-usb-dib0700-01.fw'
Jan 10 23:08:41 xxx dib0700: firmware started successfully.
Jan 10 23:08:41 xxx dvb-usb: found a 'Hauppauge Nova-T Stick' in warm state.
Jan 10 23:08:41 xxx dvb-usb: will pass the complete MPEG2 transport stream
to the software demuxer.
Jan 10 23:08:41 xxx DVB: registering new adapter (Hauppauge Nova-T Stick).
Jan 10 23:08:42 xxx DVB: registering frontend 0 (DiBcom 7000PC)...
Jan 10 23:08:42 xxx MT2060: successfully identified (IF1 = 1220)
Jan 10 23:08:42 xxx dvb-usb: Hauppauge Nova-T Stick successfully initialized
and connected.

I grabbed the channels with dvbscan and started the vdr. When running the
vdr the "tail -f /var/log/messages" in console results this:

Jan 10 23:21:36 xxx mt2060 I2C read failed
Jan 10 23:21:36 xxx mt2060 I2C read failed
Jan 10 23:21:36 xxx mt2060 I2C read failed
Jan 10 23:21:36 xxx mt2060 I2C read failed
Jan 10 23:21:36 xxx mt2060 I2C read failed
Jan 10 23:21:36 xxx mt2060 I2C read failed
Jan 10 23:21:36 xxx mt2060 I2C read failed
Jan 10 23:21:36 xxx mt2060 I2C read failed
Jan 10 23:21:37 xxx mt2060 I2C read failed
Jan 10 23:21:37 xxx mt2060 I2C read failed
Jan 10 23:21:37 xxx mt2060 I2C read failed
Jan 10 23:21:37 xxx mt2060 I2C read failed
Jan 10 23:21:37 xxx mt2060 I2C read failed
Jan 10 23:21:37 xxx mt2060 I2C read failed
Jan 10 23:21:37 xxx mt2060 I2C read failed
Jan 10 23:21:37 xxx mt2060 I2C read failed
Jan 10 23:21:37 xxx mt2060 I2C read failed
Jan 10 23:21:38 xxx mt2060 I2C read failed
Jan 10 23:21:39 xxx mt2060 I2C read failed
Jan 10 23:21:39 xxx mt2060 I2C read failed
Jan 10 23:21:39 xxx mt2060 I2C read failed
Jan 10 23:21:39 xxx mt2060 I2C read failed
Jan 10 23:21:39 xxx mt2060 I2C read failed
Jan 10 23:21:39 xxx mt2060 I2C read failed
Jan 10 23:21:39 xxx mt2060 I2C read failed
Jan 10 23:21:39 xxx mt2060 I2C read failed
Jan 10 23:21:39 xxx mt2060 I2C read failed
Jan 10 23:21:39 xxx mt2060 I2C read failed
Jan 10 23:21:40 xxx mt2060 I2C read failed
Jan 10 23:21:41 xxx mt2060 I2C read failed

I can watch some of the channels and when trying to change a channel it
works randomly. This might not be relevant but the stick has a small led
which won't lid... ;)

Thanks,

Juha
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20070110/1908f026/attachment.htm


More information about the linux-dvb mailing list