[linux-dvb] Nova-T 500 Dual DVB-T Oops

Janne Grunau janne-dvb at grunau.be
Thu Jan 11 17:35:27 CET 2007


On Thursday 11 January 2007 16:26, Michael Ditum wrote:
>
> Thanks for this patch! I was getting crashes and disconnects whilst
> using this card, tried the patch and haven't had a crash since. I was
> multicasting ~20 channels from 2 cards all of last night and didn't
> have any problems.
>
> Does anyone know of any reason this patch cannot be commited to the
> mercurial repository?

Yes, it does not help or at least it doesn't solve the issue completely. 
I have seen a crash with the patch applied. I also think that it is to 
early to say it cures the problem. The longest period I've seen without 
disconnect were 10 days (median 3-5 days).

I'm not sure that heavy usage triggers the problem. I've seen it only 
with the MythTV eit scan which uses tunes only every 5 minutes to a 
different channel and reads pids with a low data rate.
It's occurs also if Mythtv uses only one frontend.
I couldn't trigger the disconnect with dvbscan on both frontends in a 
loop for 6 hours.

Since one week I have a test system running. Unfortunately I haven't 
seen a disconnect there. I added my second card to the system this 
morning and it is still running fine. The production box had 
disconnects within 3 hours with both cards. So I'm not entirely sure 
that the test system suffers also from the disconnects.

The obvious differences between the test and production box are single 
athlon64 on a nvidia nforce4 board in the test system and dual core 
Athlon64 on via k8t800 pro.

Janne



More information about the linux-dvb mailing list