[linux-dvb] Problem with remote on ASUSTek P7131 Dual

hermann pitton hermann-pitton at arcor.de
Fri Jan 19 00:03:33 CET 2007


Am Donnerstag, den 18.01.2007, 21:24 +0100 schrieb Vincent Penne:
> Hi all,
> 
> I'm having a problem with the ASUSTeK P7131 Dual (an saa7134 based dvb 
> card) pci capture card's remote IR controller , it's handled pretty well 
> with latest linuxtv drivers, however after a while the IR remote stop 
> responding completely, and unloading/reloading the whole dvb framework 
> modules doesn't get it back working. Everything else still works  (that 
> is dvb-t still works properly, I haven't used the analogic capturing 
> features so far)
> 
> I tried to turn on debugging informations in the saa7134-input module, 
> but nothing special appears in there, before or after the IR remote 
> stops working.
> 
> 
> If you have a few pointers as to what I could try to debug the problem, 
> I'd be very happy. As far as I understand, that specific IR driver uses 
> an IRQ, so maybe that IRQ stop working for some reason ?
> 
> Here are more informations on the specific model from dmesg, this is the 
> 1043:4876 model :
> 
> saa7130/34: v4l2 driver version 0.2.14 loaded
> saa7133[0]: found at 0000:02:02.0, rev: 209, irq: 11, latency: 64, mmio: 
> 0xfddff000
> saa7133[0]: subsystem: 1043:4876, board: ASUSTeK P7131 Dual 
> [card=78,autodetected]
> saa7133[0]: board init: gpio is 40000
> input: saa7134 IR (ASUSTeK P7131 Dual) as /class/input/input3
> tuner 0-004b: chip found @ 0x96 (saa7133[0])
> tuner 0-004b: setting tuner address to 61
> tuner 0-004b: type set to tda8290+75a
> tuner 0-004b: setting tuner address to 61
> tuner 0-004b: type set to tda8290+75a
> saa7133[0]: i2c eeprom 00: 43 10 76 48 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
> saa7133[0]: i2c eeprom 10: ff ff ff 0f ff 20 ff ff ff ff ff ff ff ff ff ff
> saa7133[0]: i2c eeprom 20: 01 40 01 02 03 01 01 03 08 ff 00 d5 ff ff ff ff
> saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
> saa7133[0]: i2c eeprom 40: ff 21 00 c2 96 10 03 32 55 50 ff ff ff ff ff ff
> saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
> saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
> saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
> saa7133[0]: registered device video0 [v4l2]
> saa7133[0]: registered device vbi0
> saa7133[0]: registered device radio0
> DVB: registering new adapter (saa7133[0]).
> DVB: registering frontend 1 (Philips TDA10046H DVB-T)...
> tda1004x: setting up plls for 48MHz sampling clock
> tda1004x: found firmware revision 29 -- ok
> 
> 
> 
> Vincent Penne

Hi Vincent,

the whole thing was developed on the
subsystem: 1043:4862, board: ASUSTeK P7131 Dual device.

Unfortunately /me was the only tester over several months and nobody
else tried or gave any feed back.

The whole story started here so far on the video4linux-list.
( ... don't get the link, after all some impact of the current storm)

To have debug output you need to enable it on the ir-common module.

Didn't notice anything in that direction yet, but must admit that I was
not dedicated to long time tests. Several Sunday afternoons though.

Your card is really different from mine one. It starts with the missing
firmware eeprom. Hopefully we can get the cards in sync, else yours
should have its own entry.

Cheers,
Hermann










More information about the linux-dvb mailing list