[linux-dvb] "Unknown symbol in module" when load module saa7134

hermann pitton hermann-pitton at arcor.de
Thu Jan 25 23:02:50 CET 2007


Hi Fernando,

Am Donnerstag, den 25.01.2007, 17:33 +0100 schrieb Fernando Ruza:
> Hi,
> 
> I've downloaded the v4l-dvb source code from the cvs using mercurial
> like this (following this howto
> http://www.linuxtv.org/wiki/index.php/AverTV_DVB-T_777_PCI because I
> have an AverDVB-T 777 and I want to make remote control working):
> 
>         hg clone http://linuxtv.org/hg/v4l-dvb
> 
> I've compiled and installed succesfully with: make and make install
> however when then I load the module saa7134 I get the following error
> message:
> 
> fruza at jupiter:~/Aver777/v4l-dvb$ sudo modprobe saa7134 card=85
> FATAL: Error inserting saa7134
> (/lib/modules/2.6.18-3-k7/kernel/drivers/media/video/saa7134/saa7134.ko): Unknown symbol in module, or unknown parameter (see dmesg)
> 
> The syslog says:
> 
> Jan 25 00:25:51 localhost kernel: saa7134: Unknown symbol
> ir_codes_encore_enltv
> Jan 25 00:25:51 localhost kernel: saa7134: Unknown symbol
> ir_codes_proteus_2309
> Jan 25 00:25:51 localhost kernel: saa7134: Unknown symbol
> ir_rc5_timer_keyup
> Jan 25 00:25:51 localhost kernel: saa7134: Unknown symbol
> ir_codes_asus_pc39
> Jan 25 00:25:51 localhost kernel: saa7134: Unknown symbol
> ir_rc5_timer_end
> Jan 25 00:25:51 localhost kernel: saa7134: disagrees about version of
> symbol video_unregister_device
> Jan 25 00:25:51 localhost kernel: saa7134: Unknown symbol
> video_unregister_device
> Jan 25 00:25:51 localhost kernel: saa7134: disagrees about version of
> symbol video_device_alloc
> Jan 25 00:25:51 localhost kernel: saa7134: Unknown symbol
> video_device_alloc
> Jan 25 00:25:51 localhost kernel: saa7134: disagrees about version of
> symbol video_register_device
> Jan 25 00:25:51 localhost kernel: saa7134: Unknown symbol
> video_register_device
> Jan 25 00:25:51 localhost kernel: saa7134: disagrees about version of
> symbol video_device_release
> Jan 25 00:25:51 localhost kernel: saa7134: Unknown symbol
> video_device_release
> 
> 
> Could someone give any clue to try to solve this problem ??
> 

you have still the old ir-common and videodev modules still loaded,
likely in use by some other driver.

Try to "modprobe -vr" them, run "make rmmod" on v4l-dvb mercurial
or simply reboot.

Cheers,
Hermann





More information about the linux-dvb mailing list