[linux-dvb] Help needed with dst

Joel Michael joel at gimps-r-us.com
Tue Jul 10 15:14:47 CEST 2007


Hi,

I've just bought a 2nd hand TwinHan VisionPlus (not sure of exact model, 
but it is a DVB-S card with a CI slot), but it is not being recognised 
by the dst module.  The guy I bought it off had it working, but he's not 
contactable until next week, and he mentioned that a few settings and 
maybe a patch are going to be needed.

I tried both the in-kernel modules from 2.6.22, and the source from hg. 
  The last attempt with the hg sources resulted in the following 
messages (dst verbose=4):

bttv: driver version 0.9.17 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Bt8xx card found (0).
bttv0: Bt878 (rev 17) at 0000:05:00.0, irq: 21, latency: 64, mmio: 
0xdfefe000
bttv0: detected: Twinhan VisionPlus DVB [card=113], PCI subsystem ID is 
1822:0001
bttv0: using: Twinhan DST + clones [card=113,autodetected]
bttv0: gpio: en=00000000, out=00000000 in=00f500fd [init]
bttv0: using tuner=4
bttv0: add subdevice "dvb0"
bt878: AUDIO driver version 0.0.0 loaded
bt878: Bt878 AUDIO function found (0).
ACPI: PCI Interrupt 0000:05:00.1[A] -> GSI 21 (level, low) -> IRQ 21
bt878_probe: card id=[0x11822],[ Twinhan VisionPlus DVB ] has DVB functions.
bt878(0): Bt878 (rev 17) at 05:00.1, irq: 21, latency: 64, memory: 
0xdfeff000
dvb_bt8xx: identified card0 as bttv0
DVB: registering new adapter (bttv0).
dst(0) rdc_8820_reset: Resetting DST
dst(0) dst_gpio_outb: mask=[0004], enbb=[0004], outhigh=[0000]
dst(0) dst_gpio_outb: mask=[0004], enbb=[0004], outhigh=[0004]
dst(0) dst_comm_init: Initializing DST.
dst(0) dst_gpio_outb: mask=[ffffffff], enbb=[0001], outhigh=[0000]
dst(0) rdc_reset_state: Resetting state machine
dst(0) dst_gpio_outb: mask=[0002], enbb=[0002], outhigh=[0000]
dst(0) dst_gpio_outb: mask=[0002], enbb=[0002], outhigh=[0002]
writing [ 00 06 00 00 00 00 00 fa ]
dst(0) write_dst: _write_dst error (err == -5, len == 0x08, b0 == 0x00)
dst(0) dst_error_recovery: Trying to return from previous errors.
dst(0) dst_gpio_outb: mask=[ffffffff], enbb=[0000], outhigh=[0000]
dst(0) dst_gpio_outb: mask=[ffffffff], enbb=[0001], outhigh=[0000]
dst(0) write_dst: _write_dst error (err == -5, len == 0x08, b0 == 0x00)
dst(0) dst_error_recovery: Trying to return from previous errors.
dst(0) dst_gpio_outb: mask=[ffffffff], enbb=[0000], outhigh=[0000]
dst(0) dst_gpio_outb: mask=[ffffffff], enbb=[0001], outhigh=[0000]
dst(0) write_dst: RDC 8820 RESET
dst(0) dst_error_bailout: Trying to bailout from previous error.
dst(0) rdc_8820_reset: Resetting DST
dst(0) dst_gpio_outb: mask=[0004], enbb=[0004], outhigh=[0000]
dst(0) dst_gpio_outb: mask=[0004], enbb=[0004], outhigh=[0004]
dst(0) dst_gpio_outb: mask=[ffffffff], enbb=[0000], outhigh=[0000]
dst(0) dst_probe: unknown device.
frontend_init: Could not find a Twinhan DST.
dvb-bt8xx: A frontend driver was not found for device 109e/0878 
subsystem 1822/0001

This is the only bttv card in the machine, but there are a pair of 
FlexCopII's installed (and working fine).

Can anyone suggest anything I can try, or any debugging I can turn on to 
help?



More information about the linux-dvb mailing list