[linux-dvb] MSI TV @nywhere a/d support

Peter D. peter_s_d at fastmail.com.au
Tue Mar 20 13:17:38 CET 2007


On Tuesday 20 March 2007 18:03, Dietmar Herrendörfer wrote:
> Hello,
>
> please correct me if I am wrong, but the following issue doesn't seem to
>
> be resolved. And as I have this card working here are my five cents on 
this:
> > I have a MSI TV @nywhere A/D PCI DVB-T card that I'm trying to get
> > working on ubuntu for MythTV.
> >
> > The PCI id (or whatever it's called) is 4e42:3306.
>
> Same card here:
>
> saa7133[0]: found at 0000:00:0b.0, rev: 209, irq: 20, latency: 32, mmio:
> 0xcfff9800
[snip]

Same here too, 

Mar 20 17:07:36 live kernel: saa7133[0]: found at 0000:05:07.0, rev: 209, 
irq: 5, latency: 64, mmio: 0xfbfbf800

> > syslog:
> > tda1004x: pll set failed

Mar 20 17:08:36 live kernel: tda1004x: setting up plls for 48MHz sampling 
clock
Mar 20 17:08:38 live kernel: tda1004x: found firmware revision 29 -- ok


> I initially had the same problem myself. Some time has passed since, but
> as far as I remember I fixed this solely by extracting the firmware from
> the windows files that were on the CD that came with the card. For doing
> this I hacked the "get_dvb_firmware" script that is part of the kernel
> source (i.e. /usr/src/linux/Documentation/dvb/get_dvb_firmware).

I don't remember doing that, and mine works, although I am not using MythTV.  

> I definitely wasn't able to get the card going with the usual firmware
> for this philips chipset.

How do you tell which firmware is loaded?  I think that I am using revision 
29.  


-- 
sig goes here...
Peter D.



More information about the linux-dvb mailing list