[linux-dvb] Technisat DVB-S2 Skystar HD

Manu Abraham abraham.manu at gmail.com
Tue Oct 2 13:51:55 CEST 2007


Artem Makhutov wrote:
> Hi,
> 
> On Tue, Oct 02, 2007 at 10:40:22AM +0400, Manu Abraham wrote:
>> Artem Makhutov wrote:
>>> Hi,
>>>
>>> On Tue, Oct 02, 2007 at 03:48:38AM +0400, Manu Abraham wrote:
>>>> Artem Makhutov wrote:
>>>>> It also does not work with the modified one - I am getting a kernel ooops (see ooops.log.gz).
>>>> Please load the stb6100 module also with verbose=5
>>>>
>>>> so you can do something like this
>>>> modprobe stb6100 verbose=5
>>>> modprobe stb0899 verbose=5
>>>> modprobe budget_ci
>>>>
>>>> And get the error messages again the same way. Just need the szap and the oops messages.
>>> I have attached the new logfiles.
>>>
>> http://jusst.de/hg/multiproto/file/557067efd932/linux/drivers/media/dvb/frontends/stb6100.c
>>
>> after this line
>> 395 fvco = frequency << (1 + odiv);
>>
>> add this
>> dprintk(verbose, FE_DEBUG, 1, "fvco=%d", fvco);
>>
>> after this line
>> 397 nint = fvco / (state->reference << psd2);
>>
>> add this
>> dprintk(verbose, FE_DEBUG, 1, "Nint count=%d", nint);
>>
>>
>> and logs please.
> 
> Logs are attached.

In here

http://jusst.de/hg/multiproto/file/557067efd932/linux/drivers/media/dvb/ttpci/budget-ci.c

Change this

1680struct stb6100_config tt3200_stb6100_config = {
1681 .tuner_address = 0x60
1682};


to 

struct stb6100_config tt3200_stb6100_config = {
	.tuner_address = 0x60,
	.refclock	= 27000000, 
};

Please check whether it helps ....




More information about the linux-dvb mailing list