[linux-dvb] RE : Re: support from cx23885 driver and Xc3028 t uner for HP/Hauppauge WinTv885 mod 77001

mkrufky at linuxtv.org mkrufky at linuxtv.org
Mon Oct 15 20:49:26 CEST 2007


>
>
>     I started working on this one, but I've been held up due to firmware
>     issues-- So far, the working ATSC linux drivers for the xc3028
>     have all
>     worked when coupled with an LGDT3303 demod. In your device, we have a
>     Samsung demodulator, instead. The xc3028 requires a different
>     firmware
>     image in this case, and I haven't yet found time to work that out.
>
>     I'd expect to have the details sorted within the next month or so,
>     but I
>     don't want to make any promises.
>
aldebaran wrote:
> Dear Devs, Dear Mike,
> as you requested here below is the output of 'modprobe cx23885 i2c_scan=1'
> I'm not going to make any pressure on you, however please consider I'm 
> available for any beta testing work or any other help that could ease 
> your work.
>
> I did a little googling for the tuning chip xc3028 and found George 
> Kiagiadakis (Gkiagia) has already started working on it 
> http://mcentral.de/wiki/index.php/Xc3028 
> (http://mcentral.de/firmware/firmware_v4.tgz I tried copying these 
> firmwares inside /lib/firmware/linux-blahblah/ but Kaffeine is still 
> not able to scan for channels) maybe I should try with the 
> experimental trunk, so far I used a mercurial snapshot of 
> http://linuxtv.org/hg/v4l-dvb trunk.
Don't even bother trying to get this device up & running with any 
repositories out there right now -- it is not going to work.

I have all the code written for this device already -- it's now just a 
matter of firmware.  I have the device, too.  Once I get it working, 
you'll see it in my cx23885 tree.  I will not post the patch until I 
resolve the firmware issue.

> If you need any more information please do not hesitate to send me an 
> email!
> In the meantime I thank you for your efforts and wish you a good work.
Don't worry about it -- I have all the info that I need for this one.
>
> 192000] cx23885 driver version 0.0.1 loaded
> 192000] ACPI: PCI Interrupt 0000:04:00.0[A] -> GSI 17 (level, low) -> 
> IRQ 17
> 192000] CORE cx23885[0]: subsystem: 0070:7717, board: UNKNOWN/GENERIC 
> [card=0,autodetected]
> 292000] cx23885[0]: i2c bus 0 registered
> 304000] cx23885[0]: i2c scan: found device @ 0xa0  [eeprom]
> 312000] cx23885[0]: i2c bus 1 registered
> 328000] cx23885[0]: i2c bus 2 registered
> 332000] cx23885[0]: i2c scan: found device @ 0x66  [???]
> 332000] cx23885[0]: i2c scan: found device @ 0x88  [cx25837]
> 332000] cx23885[0]: i2c scan: found device @ 0x98  [???]
> 364000] cx23885[0]/0: found at 0000:04:00.0, rev: 2, irq: 17, latency: 
> 0, mmio: 0xf4000000

Hmm... I should have realized that you'd be sending this kind of 
output...  You'll need my patch in order to enable the right GPIO's to 
bring up the tuner / demod ic's .....  Tuner is on bus 1, demod on bus 
0.  Don't worry about this for now.

Stay tuned for more information.  If you dont hear from me within eight 
weeks, ping me again.

Regards,

Mike Krufky



More information about the linux-dvb mailing list