[linux-dvb] Twinhan 1034 question

Abylai Ospan aospan at netup.ru
Sun Sep 2 20:39:09 CEST 2007


В Вск, 02/09/2007 в 19:53 +0200, Michel Verbraak пишет:

> Abylai Ospan schreef: 
> 
> > Hello !
> > 
> > I have gentoo linux with kernel.org stock kernel 2.6.20 and I have
> > compiled and installed v4l source from
> > http://jusst.de/manu/mantis-v4l-dvb.tar.bz2  dated 01-Apr-2007 17:46
> > 4.8M.
> > 
> > After 'modprobe mantis' I'v see in dmesg:
> > 
> > ACPI: PCI Interrupt 0000:02:03.0[A] -> GSI 23 (level, low) -> IRQ 19
> > irq: 19, latency: 32
> > memory: 0xfbfff000, mmio: 0xf8826000
> > found a VP-1034 PCI DVB-S/DSS device on (02:03.0),
> >     Mantis Rev 1 [1822:0014], irq: 19, latency: 32
> >     memory: 0xfbfff000, mmio: 0xf8826000
> >     MAC Address=[00:08:ca:1a:a3:68]
> > mantis_alloc_buffers (0): DMA=0x301f0000 cpu=0xf01f0000 size=65536
> > mantis_alloc_buffers (0): RISC=0x377af000 cpu=0xf77af000 size=1000
> > DVB: registering new adapter (Mantis dvb adapter).
> > mantis_frontend_init (0): Probing for MB86A16 (DVB-S/DSS)
> > mantis_frontend_init (0): found MB86A16 DVB-S/DSS frontend @0x08
> > DVB: registering frontend 0 (Fujitsu MB86A16 DVB-S)...
> > 
> > and /dev/dvb/adapter0/ tree is created. It's looks like card
> > correctly detected.
> > But I don't see /dev/dvb/adapter0/ca0 for CI module. Is this driver
> > supports Twinhan 1034 CI interface ?
> > May be some repository with newer version is available ?
> > Thanks !
> > 
> > -- 
> > Abylai Ospan <aospan at netup.ru>
> > NetUP Inc. 
> > 
> > 
> > ____________________________________________________________________
> > 
> > _______________________________________________
> > linux-dvb mailing list
> > linux-dvb at linuxtv.org
> > http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
> 
> Currently not in the supplied open source drivers. There is a binary
> package at the Twinhan (download page) website which does support the
> CI but the modules were compiled for the first Fedore Core 6 kernel on
> a i586 platform.

Ok, thanks. But this module can't loading under linux kernel 2.6.20 (as
expected):
insmod: error inserting 'linuxdriver/v4l/mantis.ko': -1 Invalid module
format
mantis: version magic '2.6.18-1.2798.fc6 SMP mod_unload 686 REGPARM
4KSTACKS gcc-4.1' should be '2.6.20 SMP mod_unload PENTIUM4 '

Do you know how to "force" load this module ? May be some way to change
"magic" string for matching ? I don't want to install FC6 ... :)
Thanks!

-- 
Abylai Ospan <aospan at netup.ru>
NetUP Inc.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20070902/6cb6ffb1/attachment.htm 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3145 bytes
Desc: not available
Url : http://www.linuxtv.org/pipermail/linux-dvb/attachments/20070902/6cb6ffb1/attachment.bin 


More information about the linux-dvb mailing list