[linux-dvb] Avermedia M103 TV Card

Rob & Kate RobKate at nerdshack.com
Wed Apr 23 20:46:14 CEST 2008


Hi,

I'm still trying to get my avermedia M103 TV card working.

I have a Philips-Freevents LX3000 PC, on which I’m running PCLInuxOS, 
kernel 2.6.22.17.tex3 , this has an Avermedia m103 card installed (it’s 
a mini PCI card). The chips used in the card are the same as those used 
in the E506,
U5
Philips
SAA7135HL/203
CE9498 04
TSG05422

U4
Zarlink
MT352 CG
0537A WS

U2
XCEIVE
XC3018ACQ (cache)
0536ATW
K42996 2

and very similar to those used in the A16D, however following the 
instructions on mcentral.de I seem unable to get TV in XAWTV, TVTime or 
Kaffine.

The following site has managed to get this card working with the 
experimental code

http://plone.lucidsolutions.co.nz/dvb/t/compiling-mcentral-experimental-v4l-dvb-drivers 


Can you please offer some advice, a couple of things that I think may be 
the problem are

o Do I need to remove the card before I install the experimental code? 
until now I haven’t because its under the fan, but will if needs must.

o Do I need to disable the installed V4L modules in the kernel, and then 
re-compile the kernel? This seems very scary, but someone on the gentoo 
pages did it this way, so I’ll give it ago if necessary

o How do I get the xc3028 to work, there seems to be 3 different 
approaches, either download the windows firmware and convert, download 
the picnnicale firmware 
(http://mcentral.de/firmware/firmware_pinnacle.tgz), or download the 
xc3028 firmware (http://mcentral.de/firmware/firmware_v5.tgz) .


Thanks in advance for any help, this is much appreciated, & will 
hopefully mean I can stop using Vista.

Regards

Rob




More information about the linux-dvb mailing list