[linux-dvb] Hauppauge WinTV regreession from 2.6.24 to 2.6.25

Mauro Carvalho Chehab mchehab at infradead.org
Sat Apr 26 16:06:59 CEST 2008


On Sat, 26 Apr 2008 13:58:12 +0100
Ian Pickworth <ian at pickworth.me.uk> wrote:

> Mauro Carvalho Chehab wrote:
> > 
> > The issue is that set_type_addr were called at the wrong place.
> > 
> > Anyway, I've just committed a patch that should fix this for cx88. I'll soon
> > use the same logic to fix also saa7134.
> > 
> > I've also added a patch for tuner-core, to improve debug (of course, this
> > doesn't need to go to -stable). This helps to see the bug, if tuner debug is
> > enabled.
> > 
> > Cheers,
> > Mauro
> Hi Mauro,
> I have pulled the latest Mercurial source (at about 13:30 BST), compiled 
> and installed. I also removed the "tuner=38" workaround from my 
> modprobe.conf file. On reboot the WinTV cx88 card was detected correctly 
>   - thus curing the original problem in the standard 2.6.25 drivers. 
> Also, tvtime works OK with created devices - tuning to all 5 channels OK.
> The dmesg trace is below.

Thanks for your tests. Please try also to load first tuner, and then cx88.
> 
> About how long would it take for a fix like this to reach the kernel 
> tree - any chance for 2.6.25?
I'll wait for one or two days for more people to test. Then, I'll send to
mainstream, together with saa7134 fix for the same issue.

After mainstream merge, we'll send for 2.6.25. I think this should also be sent
to 2.6.24, since the same bug is present on older versions, if tuner is loaded
before cx88 or saa7134.

Btw, I've just added the corresponding saa7134 patch.

Hermann,

Could you test it please?

Cheers,
Mauro



More information about the linux-dvb mailing list