[linux-dvb] TNT Pinnacle PCTV DVB-T 72e

Antti Luoma anluoma at gmail.com
Sat Apr 26 23:22:38 CEST 2008


Hello again,


Good new! I installed new and shiny Hardy Heron (Ubuntu 8.04) and compiled
drivers from todays head-revision, booted, launched me-tv and it found my
channels ok, and ALL the channels seem to work! So somebody must have done
something because now it works with all channels..

Installed also mythtv (it complained something when it installed mysqlserver
package, but it seems to still work.

And if somebody is wondering why mythtv isn't showing any channels, just
blank screen, check channels table from mysql.. there is a bug that it
populates data with wrong multiplex_id -> you have to manually change them
with sql editor (I used Mysql Administrator / query browser)..
Mythtvfrontend seems to have some seqfaults, but sometimes it works. But
this isn't my fronted to come so I am not so annoyed with them (yet.. )


-Antti-


2008/4/24 Antti Luoma <anluoma at gmail.com>:

> Hi,
>
> Well I think it working but I'm having some issues with my mainboards
> integrated graphics card (amd 690g / radeon x1250). First when I got it
> working with 2.6.25 kernel I didn't managed to compile drivers for the for
> radeon. Then I waited a while for ubuntu guys to fix the problem from kernel
> 2.6.24 ( so that radeon drivers worked) -> Finally after that I managed to
> view the tv first time and the picture quality was ok (I really dont know
> what to compare on)... BUT there is some strange problem because if tune to
> a some channel it only show some different colors for a second and after
> that X or whole computer crashes (And only on some channels, some work ok,
> this is something that I could not understant..)! This happened few times
> and with my  poor luck it jammed my box so badly that it trashed my whole
> ext3 filesystem..
>
> After that I tried with different release (Fedora 8) and same thing
> continues. I also have been quite busy with other stuff and been waiting for
> a Hardy Hardon release day so that I can make clean install and try with
> that, I also borrowed GeForce display card to try with. I'm now downloading
> hardy so mayby I can try this at weekend and also I noticed that amd
> released new version from their drivers.
>
> But what comes to 72e stick I think it is NOW easy to install because
> v4l-dvb provides drivers that work with it ok (you need to get them from
> mercurial and compile, but nothing really amazing..).
>
>
> -Antti-
>
> 2008/4/23 Bert Haverkamp <bert at bertenselena.net>:
>
> Hello Antii,
> >
> > How is the 72e working now? I am thinking of buying it. The local
> > store has a special offer on it. Is it any good under linux?
> >
> > Regards,
> >
> > Bert
> >
> > 2008/3/31, Antti Luoma <anluoma at gmail.com>:
> > > Hi,
> > >
> > > This was a linux kernel issue, same issue that many others have
> > faced... I
> > > compiled 2.6.25-rc7 from kernel.org and now it seem to scan channels!
> > >
> > >
> > >
> > > 2008/3/20, Albert Comerma <albert.comerma at gmail.com>:
> > > > Perhaps try an other computer?
> > > >
> > > >
> > > > 2008/3/19, Antti Luoma <anluoma at gmail.com>:
> > > >
> > > > > Hi again,
> > > > >
> > > > > I borrowed Targus 7-port powered usb hub from work today and tried
> > it.
> > > At first it hang when I issued the scan -> had to reboot (usb was
> > gone).
> > > > >
> > > > > After that same usb error keeps bothering me and I can't get
> > nothing out
> > > of the tuner.
> > > > >
> > > > > 84.977573] dvb_frontend_add_event
> > > > > [   84.977663] dvb_frontend_swzigzag_autotune: drift:0 inversion:0
> > > auto_step:0 auto_sub_step:0 started_auto_step:0
> > > > > [   85.057760] dvb_frontend_ioctl
> > > > > [   85.399118] hub 6-3:1.0: port 3 disabled by hub (EMI?),
> > > re-enabling...
> > > > > [   85.399171] usb 6-3.3: USB disconnect, address 4
> > > > > [   85.399436] dvb_unregister_frontend
> > > > > [   85.399438] dvb_frontend_stop
> > > > > [   91.622120] dvb-usb: error while stopping stream.
> > > > >
> > > > > I think it disconnects the usb after the tuner finds correct
> > > signal/stream because it doesn't reset the usb if it didn't find any
> > > channels..
> > > > >
> > > > > Anyone has more ideas to try? (they are starting to be very
> > welcome)
> > > > >
> > > > >
> > > > > -antti-
> > > > >
> > > > >
> > > > >
> > > > > 2008/3/18, Antti Luoma <anluoma at gmail.com>:
> > > > > > I have get one from somewhere (hmm, maybe at work tomorrow)..
> > > > > >
> > > > > > btw I'm not alone it seemm , See
> > > http://www.mail-archive.com/linux-dvb@linuxtv.org/msg29988.html
> > > > > >
> > > > > >
> > > > > >
> > > > > > -Antti-
> > > > > >
> > > > > >
> > > > > > 2008/3/18, Albert Comerma <albert.comerma at gmail.com>:
> > > > > > > Yes I think so... try a hub if you have one near...
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > 2008/3/18, Antti Luoma <anluoma at gmail.com>:
> > > > > > > > Hmm dmesg says:
> > > > > > > >
> > > > > > > > [15046.955374] <<< 14 07
> > > > > > > > [15046.955380] >>> 03 80 00 17 01 38
> > > > > > > > [15046.955914] >>> 03 80 00 18 14 07
> > > > > > > > [15046.956420] >>> 03 80 00 17 01 38
> > > > > > > > [15046.956985] >>> 03 80 00 18 14 07
> > > > > > > > [15046.955931] >>> 02 81 01 fd
> > > > > > > > [15046.956511] <<< 7f fe
> > > > > > > > [15046.956590] >>> 0f 10 11 00
> > > > > > > > [15046.959466] hub 6-0:1.0: port 1 disabled by hub (EMI?),
> > > re-enabling...
> > > > > > > > [15046.959470] usb 6-1: USB disconnect, address 17
> > > > > > > > [15046.959655] dvb_unregister_frontend
> > > > > > > > [15046.959656] dvb_frontend_stop
> > > > > > > > [15046.961260] >>> 02 81 04 05
> > > > > > > > [15046.961267] <<< 00 00
> > > > > > > > [15046.961269] >>> 03 80 04 05 00 00
> > > > > > > > [15046.961272] ep 0 write error (status = -19, len: 6)
> > > > > > > > [15046.961273] >>> 02 81 04 06
> > > > > > > > [15046.961275] <<< 40 00
> > > > > > > > [15046.961277] >>> 03 80 04 06 42 00
> > > > > > > > [15046.961279] ep 0 write error (status = -19, len: 6)
> > > > > > > > [15046.961281] >>> 02 81 00 eb
> > > > > > > > [15046.961282] <<< 00 d0
> > > > > > > > [15046.961284] >>> 03 80 00 eb 00 32
> > > > > > > > [15046.961286] ep 0 write error (status = -19, len: 6)
> > > > > > > > [15046.961287] >>> 03 80 00 ec 07 00
> > > > > > > >
> > > > > > > >
> > > > > > > > I think this has to be USB related issue...
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > > 2008/3/18, Albert Comerma <albert.comerma at gmail.com>:
> > > > > > > > > That's very strange... You can try adding a usb hub, but I
> > don't
> > > think this should be the problem. Perhaps a kernel crash in some
> > function...
> > > but I don't see much information in your dmesg...
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > Albert
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > 2008/3/18, Antti Luoma <anluoma at gmail.com>:
> > > > > > > > > > Yes I'm sure.
> > > > > > > > > >
> > > > > > > > > > Could the problem be low power from usb? Though this is
> > the
> > > only usb device at the moment.
> > > > > > > > > >
> > > > > > > > > > I get the following line in the log after issuing scan
> > command
> > > :
> > > > > > > > > >
> > > > > > > > > > Mar 18 19:03:09 xenbuntu kernel: [13722.629120]
> > > dvb_frontend_open
> > > > > > > > > > Mar 18 19:03:09 xenbuntu kernel: [13722.629126]
> > > dvb_frontend_start
> > > > > > > > > > Mar 18 19:03:09 xenbuntu kernel: [13722.629600]
> > > dvb_frontend_ioctl
> > > > > > > > > > Mar 18 19:03:09 xenbuntu kernel: [13722.629604]
> > > dvb_frontend_thread
> > > > > > > > > > Mar 18 19:03:09 xenbuntu kernel: [13722.629605] DVB:
> > > initialising frontend 0 (DiBcom 7000PC)...
> > > > > > > > > > Mar 18 19:03:09 xenbuntu kernel: [13722.637800]
> > > dvb_frontend_ioctl
> > > > > > > > > > Mar 18 19:03:09 xenbuntu kernel: [13722.637805]
> > > dvb_frontend_add_event
> > > > > > > > > > Mar 18 19:03:09 xenbuntu kernel: [13722.637502]
> > > dvb_frontend_swzigzag_autotune: drift:0 inversion:0 auto_step:0
> > > auto_sub_step:0 started_auto_step:0
> > > > > > > > > > Mar 18 19:03:09 xenbuntu kernel: [13722.717712]
> > > dvb_frontend_ioctl
> > > > > > > > > > Mar 18 19:03:10 xenbuntu kernel: [13722.883240] usb 6-1:
> > USB
> > > disconnect, address 14
> > > > > > > > > > Mar 18 19:03:10 xenbuntu kernel: [13722.883432]
> > > dvb_unregister_frontend
> > > > > > > > > > Mar 18 19:03:10 xenbuntu kernel: [13722.883434]
> > > dvb_frontend_stop
> > > > > > > > > > Mar 18 19:03:26 xenbuntu kernel: [13729.267824]
> > > dvb_frontend_ioctl
> > > > > > > > > > Mar 18 19:03:26 xenbuntu kernel: [13729.267859]
> > > dvb_frontend_ioctl
> > > > > > > > > > Mar 18 19:03:26 xenbuntu kernel: [13729.267876]
> > > dvb_frontend_ioctl
> > > > > > > > > > Mar 18 19:03:26 xenbuntu kernel: [13729.267893]
> > > dvb_frontend_ioctl
> > > > > > > > > > Mar 18 19:03:26 xenbuntu kernel: [13729.267897]
> > > dvb_frontend_release
> > > > > > > > > > Mar 18 19:03:26 xenbuntu kernel: [13729.268363] dvb-usb:
> > > Pinnacle PCTV 72e DVB-T successfully deinitialized and disconnected.
> > > > > > > > > > Mar 18 19:03:26 xenbuntu kernel: [13729.312499] usb 6-1:
> > new
> > > high speed USB device using ehci_hcd and address 15
> > > > > > > > > > Mar 18 19:03:26 xenbuntu kernel: [13729.365651] usb 6-1:
> > > configuration #1 chosen from 1 choice
> > > > > > > > > > Mar 18 19:03:26 xenbuntu kernel: [13729.365724] dvb-usb:
> > found
> > > a 'Pinnacle PCTV 72e DVB-T' in warm state.
> > > > > > > > > > Mar 18 19:03:26 xenbuntu kernel: [13729.365841] dvb-usb:
> > will
> > > pass the complete MPEG2 transport stream to the software demuxer.
> > > > > > > > > > Mar 18 19:03:26 xenbuntu kernel: [13729.365926] DVB:
> > > registering new adapter (Pinnacle PCTV 72e DVB-T)
> > > > > > > > > > Mar 18 19:03:26 xenbuntu kernel: [13729.481923]
> > > dvb_register_frontend
> > > > > > > > > > Mar 18 19:03:26 xenbuntu kernel: [13729.481930] DVB:
> > > registering frontend 0 (DiBcom 7000PC)...
> > > > > > > > > > Mar 18 19:03:26 xenbuntu kernel: [13729.600365] DiB0070:
> > > successfully identified
> > > > > > > > > > Mar 18 19:03:26 xenbuntu kernel: [13729.600376] dvb-usb:
> > > Pinnacle PCTV 72e DVB-T successfully initialized and connected.
> > > > > > > > > >
> > > > > > > > > > It looks that it is disconnecting the device after scan
> > has
> > > started...?
> > > > > > > > > >
> > > > > > > > > > BTW this is Ubuntu 8.04 (RC4):
> > > > > > > > > > Linux xenbuntu 2.6.24-12-generic #1 SMP Wed Mar 12
> > 22:31:43
> > > UTC 2008 x86_64 GNU/Linux
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > -Antti-
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > 2008/3/18, Albert Comerma <albert.comerma at gmail.com>:
> > > > > > > > > > > Are you sure you tested with the new compiled module?
> > Could
> > > you verify that in your
> > > v4l-dvb/linux/drivers/media/dvb/dvb-usb/dib0700_devices.c
> > > you have this on the stk7070p_frontend_attach first line;
> > > > > > > > > > >
> > > > > > > > > > >        dib0700_set_gpio(adap->dev, GPIO6, GPIO_OUT,
> > 0);
> > > > > > > > > > >
> > > > > > > > > > > Because I remember with 72e that with GPIO6 set to 1
> > the
> > > tunner is disabled.
> > > > > > > > > > > Anyway, your dmesg should tell more information after
> > the
> > > failed tunning.
> > > > > > > > > > >
> > > > > > > > > > > Albert
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > 2008/3/18, Antti Luoma <anluoma at gmail.com>:
> > > > > > > > > > > > Good morning to everyone,
> > > > > > > > > > > >
> > > > > > > > > > > > I tested the Stick with windows and it found
> > channels ok..
> > > So what shall I do next?
> > > > > > > > > > > >
> > > > > > > > > > > > -antti-
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > 2008/3/18, Antti Luoma <anluoma at gmail.com>:
> > > > > > > > > > > >
> > > > > > > > > > > > > Hi,
> > > > > > > > > > > > >
> > > > > > > > > > > > > Tested with same results :( (no channels...)
> > > > > > > > > > > > >
> > > > > > > > > > > > > Tomorrow I'l (hmm today, its getting late) test
> > this
> > > with windows that it works in there...
> > > > > > > > > > > > >
> > > > > > > > > > > > > -Antti-
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > > 2008/3/18, Albert Comerma <
> > albert.comerma at gmail.com>:
> > > > > > > > > > > > >
> > > > > > > > > > > > > > Just as I pointed a few hours ago;
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > If you speak french you can have a look here;
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > http://www.louviaux.com-a.googlepages.com/tntpinnaclepctvdvb-t72e
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > Or if you don't you can go the fast way;
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > wget
> > > http://www.barbak.org/v4l_for_72e_dongle.tar.bz2
> > > > > > > > > > > > > > tar xvjf v4l_for_72e_dongle.tar.bz2
> > > > > > > > > > > > > > cd v4l-dvb
> > > > > > > > > > > > > > sudo cp
> > > firmware/dvb-usb-dib0700-1.10.fw /lib/firmware/
> > > > > > > > > > > > > > make all
> > > > > > > > > > > > > > sudo make install
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > That should work for you. Please let me know.
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > 2008/3/17, Antti Luoma <anluoma at gmail.com>:
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > Hi,
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > I have trying to get Solo Stick (72e) to work
> > for
> > > couple of days, but with no luck. So what's the current status of this
> > > driver?
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > I did download latest drivers from mercurial
> > today,
> > > added PCI_ids for card, modified dib0700_devices.c (in
> > > stk7070p_frontend_attach), added device to struct
> > dvb_usb_device_properties
> > > dib0700_devices[] where stk7070p_frontend_attach was called.
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > After that it looked promising:
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >  usb 6-4: new high speed USB device using
> > ehci_hcd
> > > and address 30
> > > > > > > > > > > > > > > [ 6722.607546] usb 6-4: configuration #1
> > chosen from
> > > 1 choice
> > > > > > > > > > > > > > > [ 6722.607622] dvb-usb: found a 'Pinnacle PCTV
> > 72e
> > > DVB-T' in warm state.
> > > > > > > > > > > > > > > [ 6722.607648] dvb-usb: will pass the complete
> > MPEG2
> > > transport stream to the software demuxer.
> > > > > > > > > > > > > > > [ 6722.607724] DVB: registering new adapter
> > > (Pinnacle PCTV 72e DVB-T)
> > > > > > > > > > > > > > > [ 6722.731734] dvb_register_frontend
> > > > > > > > > > > > > > > [ 6722.731742] DVB: registering frontend 0
> > (DiBcom
> > > 7000PC)...
> > > > > > > > > > > > > > > [ 6722.811550] DiB0070: successfully
> > identified
> > > > > > > > > > > > > > > [ 6722.811557] dvb-usb: Pinnacle PCTV 72e
> > DVB-T
> > > successfully initialized and connected.
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > BUT if I do a scan I don't get channels (i
> > checked
> > > that I have correct frequencies):
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >  #scan -o vdr  fi-Eurajoki
> > > > > > > > > > > > > > > scanning fi-Eurajoki
> > > > > > > > > > > > > > > using '/dev/dvb/adapter0/frontend0' and
> > > '/dev/dvb/adapter0/demux0'
> > > > > > > > > > > > > > > initial transponder 610000000 0 2 9 3 1 2 0
> > > > > > > > > > > > > > > initial transponder 666000000 0 2 9 3 1 2 0
> > > > > > > > > > > > > > > initial transponder 722000000 0 2 9 3 1 2 0
> > > > > > > > > > > > > > > >>> tune to:
> > > 610000:I999B8C23D999M64T8G8Y0:T:27500:
> > > > > > > > > > > > > > > WARNING: filter timeout pid 0x0011
> > > > > > > > > > > > > > > WARNING: filter timeout pid 0x0000
> > > > > > > > > > > > > > > WARNING: filter timeout pid 0x0010
> > > > > > > > > > > > > > > >>> tune to:
> > > 666000:I999B8C23D999M64T8G8Y0:T:27500:
> > > > > > > > > > > > > > > __tune_to_transponder:1483: ERROR: Setting
> > frontend
> > > parameters failed: 19 No such device
> > > > > > > > > > > > > > > >>> tune to:
> > > 666000:I999B8C23D999M64T8G8Y0:T:27500:
> > > > > > > > > > > > > > > __tune_to_transponder:1483: ERROR: Setting
> > frontend
> > > parameters failed: 19 No such device
> > > > > > > > > > > > > > > >>> tune to:
> > > 722000:I999B8C23D999M64T8G8Y0:T:27500:
> > > > > > > > > > > > > > > __tune_to_transponder:1483: ERROR: Setting
> > frontend
> > > parameters failed: 19 No such device
> > > > > > > > > > > > > > > >>> tune to:
> > > 722000:I999B8C23D999M64T8G8Y0:T:27500:
> > > > > > > > > > > > > > > __tune_to_transponder:1483: ERROR: Setting
> > frontend
> > > parameters failed: 19 No such device
> > > > > > > > > > > > > > > dumping lists (0 services)
> > > > > > > > > > > > > > > Done.
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > Any thoughts??
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > --
> > > > > > > > > > > > > > > -Antti-
> > > > > > > > > > > > > > >
> > > _______________________________________________
> > > > > > > > > > > > > > > linux-dvb mailing list
> > > > > > > > > > > > > > > linux-dvb at linuxtv.org
> > > > > > > > > > > > > > >
> > > http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > > --
> > > > > > > > > > > > > -Antti-
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > --
> > > > > > > > > > > > -Antti-
> > > > > > > > > > > >
> > > _______________________________________________
> > > > > > > > > > > > linux-dvb mailing list
> > > > > > > > > > > > linux-dvb at linuxtv.org
> > > > > > > > > > > >
> > > http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > --
> > > > > > > > > > -Antti-
> > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > > --
> > > > > > > > -Antti-
> > > > > > >
> > > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > > --
> > > > > > -Antti-
> > > > >
> > > > >
> > > > >
> > > > > --
> > > > > -Antti-
> > > >
> > > >
> > >
> > >
> > >
> > > --
> > > -Antti-
> > > _______________________________________________
> > >  linux-dvb mailing list
> > >  linux-dvb at linuxtv.org
> > >  http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
> > >
> >
> >
> > --
> > -----------------------------------------------------
> > There are 10 kind op people in the world:
> > those who understand binary, and those who don't.
> >
>
>
>
> --
> -Antti-




-- 
-Antti-
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20080427/0a2dab3b/attachment-0001.htm 


More information about the linux-dvb mailing list