[linux-dvb] HVR-1800 failing to detect any QAM256 channels

Eric Cronin ecronin at gizmolabs.org
Wed Apr 30 19:03:07 CEST 2008


Hello,

I have an HP Pavilion OEM'd HVR-1800 that I'm giving a shot at getting  
working (PVR-500 and HDHR are my production analog/digital inputs).

I'm running Mythbuntu 8.04 and have tried both with the bundled  
version of v4l-dvb modules and a hg copy from April 29, and both have  
the same problem:

The card is detected fine and /dev/dvb/* created.  When I run 'scan us- 
Cable-Standard-center-frequencies-QAM256' it detects nothing, even on  
frequencies which I know are QAM256 from the HDHR which is 12" of coax  
away from the HVR-1800.  Here is an example from the HDHR scan:

SCANNING: 759000000 (us-cable:118, us-irc:118)
LOCK: qam256 (ss=90 snq=52 seq=100)
PROGRAM: 1: 6.1 WPVI-HD
PROGRAM: 2: 10.1 WCAU-DT
PROGRAM: 3: 6.2 WPVI-SD
PROGRAM: 4: 6.3 WPVI-WX
PROGRAM: 5: 10.2 WX-PLUS

and from 'scan -v test-chan118' which has just 759000000 in it:

scanning test-chan118
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
 >>> tune to: 759000000:QAM_256
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
WARNING: >>> tuning failed!!!
 >>> tune to: 759000000:QAM_256 (tuning failed)
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
 >>> tuning status == 0x00
WARNING: >>> tuning failed!!!
ERROR: initial tuning failed
dumping lists (0 services)
Done.

I have checked the physical connections best I can.  Connecting the  
HVR-1800's coax to the PVR-500 sees the analog side of things fine,  
and the correct jack on the HVR-1800 is being used.

I'm not sure where to go from here debugging things, any suggestions  
or more data I can provide?  The modprobe-produced info from dmesg is  
at the end of this message.

Thanks,
Eric

[67182.599444] cx23885 driver version 0.0.1 loaded
[67182.599631] ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 17 (level,  
low) -> IRQ 17
[67182.599870] CORE cx23885[0]: subsystem: 0070:7801, board: Hauppauge  
WinTV-HVR1800 [card=2,autodetected]
[67182.762076] cx23885[0]: i2c bus 0 registered
[67182.764615] tuner' 2-0042: chip found @ 0x84 (cx23885[0])
[67182.799857] tda829x 2-0042: could not clearly identify tuner  
address, defaulting to 60
[67182.823174] tda18271 2-0060: creating new instance
[67182.859178] TDA18271HD/C1 detected @ 2-0060
[67184.029322] tda829x 2-0042: type set to tda8295+18271
[67185.226752] cx23885[0]: i2c bus 1 registered
[67185.229777] msp3400' 3-0044: MSP5431H-^8 found @ 0x88 (cx23885[0])
[67185.229782] msp3400' 3-0044: MSP5431H-^8 supports radio, mode is  
autodetect and autoselect
[67185.229980] cx23885[0]: i2c bus 2 registered
[67185.257210] tveeprom 1-0050: Hauppauge model 78521, rev C1E9,  
serial# 2639463
[67185.257214] tveeprom 1-0050: MAC address is 00-0D-FE-28-46-67
[67185.257217] tveeprom 1-0050: tuner model is Philips 18271_8295 (idx  
149, type 54)
[67185.257220] tveeprom 1-0050: TV standards NTSC(M) ATSC/DVB Digital  
(eeprom 0x88)
[67185.257223] tveeprom 1-0050: audio processor is CX23887 (idx 42)
[67185.257226] tveeprom 1-0050: decoder processor is CX23887 (idx 37)
[67185.257228] tveeprom 1-0050: has radio, has no IR receiver, has no  
IR transmitter
[67185.257231] cx23885[0]: hauppauge eeprom: model=78521
[67185.343514] cx23885[0]/0: registered device video1 [v4l2]
[67186.513413] cx23885[0]: registered device video2 [mpeg]
[67186.513419] cx23885[0]: cx23885 based dvb card
[67186.544894] MT2131: successfully identified at address 0x61
[67186.544901] DVB: registering new adapter (cx23885[0])
[67186.544905] DVB: registering frontend 0 (Samsung S5H1409 QAM/8VSB  
Frontend)...
[67186.546383] cx23885_dev_checkrevision() Hardware revision = 0xb1
[67186.546396] cx23885[0]/0: found at 0000:02:00.0, rev: 15, irq: 17,  
latency: 0, mmio: 0xf9e00000
[67186.546407] PCI: Setting latency timer of device 0000:02:00.0 to 64
-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 486 bytes
Desc: This is a digitally signed message part
Url : http://www.linuxtv.org/pipermail/linux-dvb/attachments/20080430/c8ae9a2f/attachment-0001.pgp 


More information about the linux-dvb mailing list