[linux-dvb] HVR-1600 - No audio

hermann pitton hermann-pitton at arcor.de
Tue Aug 5 04:36:21 CEST 2008


Am Montag, den 04.08.2008, 21:57 -0400 schrieb Andy Walls:
> On Mon, 2008-08-04 at 20:07 +0200, hermann pitton wrote:
> > Am Sonntag, den 03.08.2008, 22:35 -0400 schrieb Andy Walls:
> > > On Mon, 2008-08-04 at 02:44 +0200, hermann pitton wrote:
> > > > Am Sonntag, den 03.08.2008, 15:20 -0400 schrieb Andy Walls:
> > > > > On Sun, 2008-08-03 at 10:49 -0700, Brian Steele wrote:
>  
> > > I have two HVR-1600's: one with radio and one without.  I can't check
> > > the one without radio right now (that computer is down for other
> > > experiments).
> 
> Brian,
> 
> I have been able to test my HVR-1600 that has a TCL M2523.  For the
> record, using tuner type 50, the tuner audio for analog captures works
> for me with the latest v4l-dvb.
> 
> Here's how the initialization looks without any debug turned on.
> 
> cx18:  Start initialization, version 1.0.0
> cx18-0: Initializing card #0
> cx18-0: Autodetected Hauppauge card
> ACPI: PCI Interrupt 0000:03:03.0[A] -> GSI 21 (level, low) -> IRQ 21
> cx18-0: cx23418 revision 01010000 (B)
> tveeprom 1-0050: Hauppauge model 74041, rev C5B2, serial# 891351
> tveeprom 1-0050: MAC address is 00-0D-FE-0D-99-D7
> tveeprom 1-0050: tuner model is TCL M2523_5N_E (idx 112, type 50)
> tveeprom 1-0050: TV standards NTSC(M) (eeprom 0x08)
> tveeprom 1-0050: audio processor is CX23418 (idx 38)
> tveeprom 1-0050: decoder processor is CX23418 (idx 31)
> tveeprom 1-0050: has no radio, has IR receiver, has IR transmitter
> cx18-0: Autodetected Hauppauge HVR-1600
> cx18-0: VBI is not yet supported
> tuner 2-0061: chip found @ 0xc2 (cx18 i2c driver #0-1)
> cs5345 1-004c: chip found @ 0x98 (cx18 i2c driver #0-0)
> tuner-simple 2-0061: creating new instance
> tuner-simple 2-0061: type set to 50 (TCL 2002N)
> cx18-0: Disabled encoder IDX device
> cx18-0: Registered device video0 for encoder MPEG (2 MB)
> DVB: registering new adapter (cx18)
> cx18-0: loaded v4l-cx23418-apu.fw firmware V00120000 (141200 bytes)
> MXL5005S: Attached at address 0x63
> DVB: registering frontend 0 (Samsung S5H1409 QAM/8VSB Frontend)...
> cx18-0: DVB Frontend registered
> cx18-0: loaded v4l-cx23418-cpu.fw firmware (158332 bytes)
> cx18-0: FW version: 0.0.74.0 (Release 2007/03/12)
> cx18-0: loaded v4l-cx23418-dig.fw firmware (16382 bytes)
> cx18-0: Registered device video32 for encoder YUV (2 MB)
> cx18-0: Registered device video24 for encoder PCM audio (1 MB)
> cx18-0: Initialized card #0: Hauppauge HVR-1600
> cx18:  End initialization
> 
> 
> When we initially had a problem with the cx-18 not producing any audio
> from the tuner, it was because there was errors in the microcontroller
> firmware load.  Hans' made a fix to make the firmware load more robust
> and things started working.  If your tuner looks like it's getting
> commanded properly, we'll investigate microcontroller firmware load
> next.
> 
> 
> 
>  
> > > Does a TCL M2523_5N_E have a TDA988x?  I know the TDA9887 can
> > > demodulate FM radio. Brian's HVR-1600 doesn't have FM radio according to
> > > tveeeprom, so are you thinking a TDA988[56] is in the TCL M2523 5N E? 
> > 
> > No, therefore the warning that I did not look any closer yet.
> > 
> > http://www.tclrf.com/English/html/enewsproopen.asp?proname=102&url=product
> 
> Hermanm,
> 
> Thank you for the link.  From the link you gave:
> 
> ·IC type: SN761678 & TDA9801T
> 
> So a TDA9801 is the demodulator-PLL chip on this TCL tuner.  Thanks.
> 
> 
> > > "struct tuner_params tuner_tcl_2002n_params[]" in
> > > v4l-dvb/linux/drivers/media/common/tuners/tuner-types.c
> > > doesn't have ".has_tda9887 = 1" set.
> > 
> > I assumed a MK4 tuner=57 on it like it is also on PVR-150 and PVR-500.
> > They also have no radio, but without tda9887, includes tda9885 and
> > tda9886, you won't get anything useful out of them.
> 
> My PVR-150MCE has an LG TAPE H001F (type 47).  The tape is a rebranded
> Phillips FM1236 MK3 (type 43) and it does have a tda988x.  I figured out
> a few years ago how to get the FM radio working right for the TAPE
> H001F, and Hans' helped me figure that the TAPE H001F was a clone of the
> FM1236 MK3.
> 
> 
> 
> > Then exactly the above missing .has_tda9887 = 1 for _that one_ could
> > cause such problems.
> > 
> 
> > It just came in mind it might be related to the missing tda9887 for
> > tuner=57, but you obviously deal with other tuners.
> 
> Now I understand you original meaning. OK.
> 
> 
> > However, the missing tda9887 for the FQ1236A seems to be at least a
> > inconsistency in tuner-types.c for me.
> 
> For the FQ1236A MK4 It looks inconsistent to me too.  You're probably
> right.  I don't have a PVR card with that tuner to test though, and I
> can't find a datasheet for the FQ1236A MK4 to verify your observation. 

We are in the damned same boat here!

Hans, what do you say?

> 
> Regards,
> Andy
> 
> > >From logs of the PVR-500 and PVR-150 one can see they need the tda9887
> > module and it is at 0x43/0x86.

I even started to believe, that this could be a variant having the
tda98xx stuff strapped to be hardwired for System-M, hard to believe and
I was even involved previously to get something out of them at all ...

This could be possible, but it was all bullshit even to think about it.

Why that FQ1236A has no support for tda9887 in tuner-types.c ?

I don't even ask it the first time ....

Cheers,
Hermann







More information about the linux-dvb mailing list