[linux-dvb] HVR-4000 driver problems - i2c error

Steven Toth stoth at linuxtv.org
Mon Aug 18 20:10:06 CEST 2008


Ales Jurik wrote:
> Hi,
> 
> I've got a HVR-4000, but I have now some very strange problems.
> I have Debian Leeny with 2.6.25-2 kernel and multiproto from Igor Lipianin hg 
> running at Athlon64 X2 2700+ and Asus M2N-DVI mobo. 
> Whole multiproto tree compiled without any problem.
> 
> - when starting system I got this message:
> 
> [   24.658572] tda9887 0-0043: i2c i/o error: rc == -121 (should be 4)
> [   24.659047] tuner-simple 0-0061: i2c i/o error: rc == -121 (should be 4)
> [   23.609971] tda9887 0-0043: i2c i/o error: rc == -121 (should be 4)
> 
> - the firmware is loaded into the card at first time the card is opened - it 
> is okay?
> 
> [  917.660620] cx24116_firmware_ondemand: Waiting for firmware upload 
> (dvb-fe-cx24116.fw)...
> [  917.703010] cx24116_firmware_ondemand: Waiting for firmware upload(2)...
> [  922.703870] cx24116_load_firmware: FW version 1.22.82.0
> [  922.703889] cx24116_firmware_ondemand: Firmware upload complete
> 
> The result is that only for some channels it is possible to get lock with 
> szap2. VDR is hanging (or starting) when trying to tune to initial channel, 
> even when this channel is set to channel at which is szap2 successfull. I'm 
> not able to say criteria which channels are possible to lock.
> 
> Any hints are appreciated.

I fixed an issue with cx88 sometime ago where a value of 0 (taken from 
the cards struct) was being written to the GPIO register, resulting in 
the same i2c issues.

It looks a lot like this.

- Steve





More information about the linux-dvb mailing list