[linux-dvb] gspca drivers

James Klaas jklaas at appalachian.dyndns.org
Sat Feb 2 02:47:33 CET 2008


On 1/31/08, Brandon Philips <brandon at ifup.org> wrote:
> On 18:33 Thu 31 Jan 2008, James Klaas wrote:
> > I was hoping to get my webcam working with the latest v4l-dvb sources.
> >  After reading about on this list and elsewhere, I ran:
> >
> > # make kernel-links
> >
> > from my v4l-dvb directory in order to modify my current linux sources
> > to use the v4l-dvb drivers.  Then I went to my gspca directory and ran
> > the "gspca_build" script:
> >
> > ./gspca_build
> >
> >  REMOVE the old module if present
> > Unknown symbol in module, or unknown parameter (see dmesg)
> >
> >  PRINT COMPILATION MESSAGES if ERRORS look kgspca.err
> > make -C /lib/modules/`uname -r`/build SUBDIRS=/usr/src/modules/gspca
> > CC=cc modules
> > make[1]: Entering directory `/usr/src/linux-source-2.6.22'
> >   CC [M]  /usr/src/modules/gspca/gspca_core.o
> > /usr/src/modules/gspca/gspca_core.c:2542: error: unknown field
> > 'hardware' specified in initializer
>
> Are you using the latest gspca driver?  The hardware field was removed
> months ago.

I just picked up gspcav1-20071224
(http://mxhaard.free.fr/spca50x/Download/gspcav1-20071224.tar.gz) and
I get the same error.    Is there a later version somewhere else?

>
> Thanks,
>
>         Brandon
>

James



More information about the linux-dvb mailing list