[linux-dvb] gspca drivers

Brandon Philips brandon at ifup.org
Fri Feb 8 00:35:07 CET 2008


On 21:08 Fri 01 Feb 2008, James Klaas wrote:
> On 1/31/08, Brandon Philips <brandon at ifup.org> wrote:
> > On 18:33 Thu 31 Jan 2008, James Klaas wrote:
> > > I was hoping to get my webcam working with the latest v4l-dvb sources.
> > >  After reading about on this list and elsewhere, I ran:
> > >
> > > # make kernel-links
> > >
> > > from my v4l-dvb directory in order to modify my current linux sources
> > > to use the v4l-dvb drivers.  Then I went to my gspca directory and ran
> > > the "gspca_build" script:
> > >
> > > ./gspca_build
> > >
> > >  REMOVE the old module if present
> > > Unknown symbol in module, or unknown parameter (see dmesg)
> > >
> > >  PRINT COMPILATION MESSAGES if ERRORS look kgspca.err
> > > make -C /lib/modules/`uname -r`/build SUBDIRS=/usr/src/modules/gspca
> > > CC=cc modules
> > > make[1]: Entering directory `/usr/src/linux-source-2.6.22'
> > >   CC [M]  /usr/src/modules/gspca/gspca_core.o
> > > /usr/src/modules/gspca/gspca_core.c:2542: error: unknown field
> > > 'hardware' specified in initializer
> >
> > Are you using the latest gspca driver?  The hardware field was removed
> > months ago.
> 
> [ 1026.765596] gspca: disagrees about version of symbol video_devdata
...
> [ 1977.737339] gspca: Unknown symbol video_device_release

Did you "make install" the v4l tree you built against and make sure none
of the old video modules were loaded (see lsmod) when you modprobe'd
gspca?

Thanks,

	Brandon



More information about the linux-dvb mailing list